Jump to: Board index » General » Fusion

Why my Fusion Composition is Extremely Slow

Learn about 3D compositing, animation, broadcast design and VFX workflows.
  • Author
  • Message
Offline

arkanafif

  • Posts: 1
  • Joined: Tue Nov 19, 2019 9:47 am
  • Real Name: Arkan Afif

Why my Fusion Composition is Extremely Slow

PostSat Dec 14, 2019 9:38 am

Hello, I want to ask whether if my system is too slow or I have a wrong pipeline on this:

I recently make a simple composition for my compositing practice, it is a 7 seconds BMPCC 6K BRAW footage. I set the timeline to 1920x1080 @25fps, I already nest the 6K footage so the Fusion will compose the footage on 1080p resolution. I use DaVinci Resolve Studio 16.1. Here is the final output:

https://youtu.be/ARr1NrzfbJ0

p.s: I made 2 types of flying effects with the same footage, the screenshot of Fusion node is in here:
Screenshot from 2019-12-14 16-13-56.png
Fusion Node Screenshot
Screenshot from 2019-12-14 16-13-56.png (230.07 KiB) Viewed 370 times


Here is the recap of my workflow:
1. Import a BRAW 6K footage.
2. Create a 1080p 25fps timeline.
3. Insert BRAW footage to the timeline.
4. Right-click then 'New Fusion Clip...' (so the Fusion will process the comp. at 1080p instead of 6K).
5. I check these parameters on the Project Settings:
5a. 'Automatically cache composites in User Mode'.
5b. 'Automatically cache Fusion Effects in User Mode'.
6. I also set these parameters on the Playback menubar:
6a. 'Use Optimized Media if Available'.
6b. 'Render Cache' set to 'User'.
6c. 'Fusion Memory Cache' set to 'On'.
7. Start compositing.
8. Creating mesh for camera projection in the Blender (FBX workflow).
9. Send the FBX mesh from Blender to Resolve Fusion.
10. Camera projection.
11. Compositing & adjustment.

However, this is the problem that I face:
1. As the composite grows complex, the cache isn't getting smooth anymore.
2. The MediaOut node usually won't feed into the Resolve timeline (just a few frames, and then it will stop feeding).
3. As the point number 2 happen, I render out the sequence with the Saver node, so I can make a smooth playback on the Resolve timeline, but it is painfully slow, 20min for just 6sec.

This is my system specifications:
Intel Core i7 8700K (OC-ed to 4.5GHz)
Asus Strix RTX 2070 8GB
Corsair DDR4-3200 32GB (2x16GB)
MSI Z370 A-PRO
Samsung SSD 860 Pro 1TB
Ubuntu 19.10

Is it my system that is too slow or I have a wrong workflow? Thanks in advance! :)

Return to Fusion

Who is online

Users browsing this forum: No registered users and 12 guests