Page 1 of 1

Shader goes dark in viewer on right click and doesn't return

PostPosted: Mon Dec 30, 2019 6:04 pm
by fullmetalfilm
I'm working my way through the training PDF for Fusion that Blackmagic provides. I've started playing with shaders. I drag a single Chrome shader node into the nodes. I click 1 to see it in the viewer. I see the default sphere showing the material. Right clicking and dragging or simply right clicking in the viewer makes the shader go dark as if the light in the viewer has been turned way down.

If I view the same node in viewer 2, I can see it lit up. Viewer 1 shows it dark. So this is a viewer issue, not something that is being changed on the node.

The viewer settings appear identical in both viewer 1 and 2, so I can't tell what the right click changes. I also can't figure out how to make it come back without deleting that node and re-adding it, at which point it appears lit in the viewers until I right click again.

[Correction: Deleting the node and re-adding it doesn't fix the issue. I'm now stuck with both viewers preview shaders darkened] (edited)

This isn't a huge issue because obviously I'm just previewing the shader in a default shape. Although it is inconvenient because I can't preview other shapes because that requires a right-click which turns the lights out.

Anyone seen this or have any suggestions how to fix it?

Thanks,

Mark.

Re: Shader goes dark in viewer on right click and doesn't re

PostPosted: Mon Dec 30, 2019 6:25 pm
by fullmetalfilm
Right clicking in the viewer and selecting to uncheck "Enable lighting" fixes this. I'm not sure why the initial right clicking caused the viewer to go dark after it was lit. Perhaps someone can explain this.

Re: Shader goes dark in viewer on right click and doesn't re

PostPosted: Mon Dec 30, 2019 6:49 pm
by xunile
Are you right-clicking and dragging or middle-clicking and dragging? On my system, right clicking does nothing but bring up a context menu. Middle-clicking and dragging changes where the light source is in the Material viewer.

Re: Shader goes dark in viewer on right click and doesn't re

PostPosted: Mon Dec 30, 2019 7:14 pm
by fullmetalfilm
I'm actually on a trackpad and I'm clicking with both fingers which is a "secondary click" - basically a right click. I don't have a mouse, so no middle mouse button. I use modifiers with a two finger click or drag to get what I want e.g. holding shift and dragging both fingers moves my view around the object in a spherical pattern.

Re: Shader goes dark in viewer on right click and doesn't re

PostPosted: Mon Dec 30, 2019 7:22 pm
by xunile
It is the pinch to zoom function of your trackpad that causes the issue, I just tried it with the trackpad on my laptop, the same thing happened. I rarely use the trackpad on my laptop, I use a mouse with a scroll wheel, works much better.

Re: Shader goes dark in viewer on right click and doesn't re

PostPosted: Mon Dec 30, 2019 7:35 pm
by fullmetalfilm
Sorry about the demo mode thing. This illustrates the issue.


Re: Shader goes dark in viewer on right click and doesn't re

PostPosted: Mon Dec 30, 2019 7:49 pm
by xunile
You can try right-clicking, choose Lighting>Light Position and then one of the selections.

Re: Shader goes dark in viewer on right click and doesn't re

PostPosted: Mon Dec 30, 2019 8:09 pm
by fullmetalfilm
This really feels like a bug. Yes, when I change the lighting position, the light turns back on. But as soon as a click the trackpad in the viewer with both fingers the light turns out, until I select a new angle, at which point it turns on again.

Re: Shader goes dark in viewer on right click and doesn't re

PostPosted: Thu May 07, 2020 2:03 pm
by federicoruggeri
Hello everybody!
I am studying the Fusion guide too and when I drag the Chrome shader to the node area and then click it to see it in the viewer it appears pixelated and of random colors (left) instead of how it is shown on the book (right). Is this a bug of some sort?
Does anyone know how to fix this? Thank you

Chrome shader.jpg
Chrome shader.jpg (895.63 KiB) Viewed 101 times

Re: Shader goes dark in viewer on right click and doesn't re

PostPosted: Thu May 07, 2020 3:18 pm
by Bryan Ray
Whoah. Yeah, that's definitely not right. My guess would be a GPU issue of some kind. What are your system specs, and which version of Fusion or Resolve are you using?

If you open up the group and disconnect the Reflect node from the Ward, does it look like the shader on the left? If you look at the Reflect node on its own, it should look like the one on the right:

Capture.JPG
Capture.JPG (82.39 KiB) Viewed 95 times