Jump to: Board index » General » Fusion

FusionRenderNode.exe

Learn about 3D compositing, animation, broadcast design and VFX workflows.
  • Author
  • Message
Offline

Nicolas

  • Posts: 5
  • Joined: Thu Jan 02, 2020 10:00 am
  • Real Name: Nicolas Genette

FusionRenderNode.exe

PostMon Jan 06, 2020 5:07 pm

Hi,

I'm writing a python tool to submit Fusion comp files to BackBurner.
No problem on this part, but:

I'm totally new to Fusion. Installed both Fusion Studio and Fusion RenderNode
I have the usb dongle plugged and Fusion Studio works fine.

Now I run :
C:\FusionNode\FusionRenderNode.exe D:\test1.comp /log D:\fusion.txt /cleanlog /verbose /render /start 0 /end 10 /step 1 /status /quit


But nothing renders and have this error:

Registering System Sounds
Initialising Scripting Subsystem
Cannot locate license server
Fusion Render Node halted.

I've tried, reading some forum, to set FUSION_LICENSE_SERVER in env variables with my IP, but doesn't work either.

Anyone having some explanations on how to render with rendernode ?

Also, is it possible to start FusionRenderNode.exe with specifying the saver node to render ? Or will it take all enabled savers ?

Thanks
Offline

Nicolas

  • Posts: 5
  • Joined: Thu Jan 02, 2020 10:00 am
  • Real Name: Nicolas Genette

Re: FusionRenderNode.exe

PostMon Jan 06, 2020 7:45 pm

Ok, all is working now, was a firewall problem, found on another topic.

Not much documentation on creating GUI with python inside Fusion anyway, but have sorted it out getting all needed and calling an external python script with pyqt.
Offline
User avatar

Igor Riđanović

  • Posts: 812
  • Joined: Thu Jul 02, 2015 5:11 am
  • Location: Los Angeles, Calif.

Re: FusionRenderNode.exe

PostWed Jan 08, 2020 8:24 pm

Whatever Qt is accessible from within Fusion or Resolve seems to be very limited, or as you correctly say, poorly documented. It's way easier just to use the PyQt.
www.metafide.com - DaVinci Resolve™ Apps

Return to Fusion

Who is online

Users browsing this forum: No registered users and 11 guests