Jump to: Board index » General » Fusion

Request: Python 3.7 support according to VFXPlatform

Learn about 3D compositing, animation, broadcast design and VFX workflows.
  • Author
  • Message
Offline
User avatar

Blazej Floch

  • Posts: 189
  • Joined: Tue Nov 11, 2014 12:48 am
  • Location: Toronto, ON

Request: Python 3.7 support according to VFXPlatform

PostMon Mar 29, 2021 8:13 pm

Can Fusion support Python version matching the http://vfxplatform.com/ ?

Currently 3.7 as opposed to 3.6. The Option to use 2.7 is excellent. All we need now is 3.7 so that pipeline transitions can reuse the same codebase. It's expensive to maintain 3.6 and we need to call subprocesses into incompatible code or maintain 3.6 compatibility. rez package maintenance becomes a nightmare.

Closest past reference, although I do not second 3.8. Please stick to VFX Ref Platform.
viewtopic.php?f=22&t=121039&p=664591&hilit=python+3.7#p664591

Thanks.

Return to Fusion

Who is online

Users browsing this forum: No registered users and 10 guests