Jump to: Board index » General » Fusion

Whaaaattt !??!! No alpha exported in ProRes 4444 ! [Solved]

Learn about 3D compositing, animation, broadcast design and VFX workflows.
  • Author
  • Message
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Whaaaattt !??!! No alpha exported in ProRes 4444 ! [Solved]

PostTue Mar 15, 2022 5:30 pm

Hi there,

I just moved on a M1 macmini (very impressive btw) for my 2 next projects...

I just discovered that no alpha channel was exported in a prores 4444 file (by the way, no check box available for alpha in the saver node parameters, so I thought it may default to keep the alpha wen PR 4444 chosen).

This is a huuuuuuge issue in a compositing soft. don't you think ? :o :o :evil:

Now, this Fusion Studio 17.4.2 build 11 on a M1, so is there any other version available anywhere which works the right way on a silicon Mac please ?

THX in advance
Last edited by Sam Steti on Thu Jul 21, 2022 9:53 am, edited 1 time in total.
*MacMini M1 16 Go - Ext nvme SSD
*Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches
*Resolve Studio everywhere, Fusion Studio too
*https://www.buymeacoffee.com/samalaplaya
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Whaaaattt !??!! No alpha eported in ProRes 4444 !

PostTue Mar 15, 2022 7:02 pm

Yeah, you saw 17.4.2 build 11...

I realized and DL the 17.4.5 : I think you know it still doesn't work...
Offline

Hendrik Proosa

  • Posts: 2397
  • Joined: Wed Aug 22, 2012 6:53 am
  • Location: Estonia

Re: Whaaaattt !??!! No alpha eported in ProRes 4444 !

PostWed Mar 16, 2022 8:11 am

Sam Steti wrote:This is a huuuuuuge issue in a compositing soft. don't you think ? :o :o :evil:

Obviously not. viewtopic.php?f=22&t=153684
I do stuff.
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Whaaaattt !??!! No alpha eported in ProRes 4444 !

PostWed Mar 16, 2022 12:10 pm

You mean "obviously not" because it was a known issue still not fixed (which means BMD doesn't care) ?
I hope that was your idea... Because what could be a compositing app without alpha channel... :evil:

And still : is there a known version which doesn't lack this ultra major feature ?
(just not to DL and try x version)
*MacMini M1 16 Go - Ext nvme SSD
*Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches
*Resolve Studio everywhere, Fusion Studio too
*https://www.buymeacoffee.com/samalaplaya
Offline

alan bovine

  • Posts: 145
  • Joined: Mon Aug 07, 2017 6:20 pm

Re: Whaaaattt !??!! No alpha eported in ProRes 4444 !

PostWed Mar 16, 2022 4:11 pm

Obviously because if you're doing compositing with extra channels there are no better format than EXR.
Fusion video tutorials : https://www.youtube.com/channel/UCTCeDas53OEcWcRujkQiwLg/videos?view_as=subscriber
Fusion Tools : https://github.com/statixVFX/stx_tools
Nuke 2 Fusion nodes : https://github.com/statixVFX/nuke2fusion
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Whaaaattt !??!! No alpha eported in ProRes 4444 !

PostWed Mar 16, 2022 7:04 pm

alan bovine wrote:Obviously because if you're doing compositing with extra channels there are no better format than EXR.

Oh ok... I missed that point. Thank you very much then
Fortunately you came here to open my eyes on EXR... Hopefully you will send me tutorials on cryptomatte (anyway it may be a natural next post, sounds great, never ever seen...)

Now I know why we cannot export pr 4444 with alpha channel anymore...
*MacMini M1 16 Go - Ext nvme SSD
*Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches
*Resolve Studio everywhere, Fusion Studio too
*https://www.buymeacoffee.com/samalaplaya
Offline

Hendrik Proosa

  • Posts: 2397
  • Joined: Wed Aug 22, 2012 6:53 am
  • Location: Estonia

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostThu Mar 17, 2022 8:26 am

Alpha channel is so 80-s, modern comping is RGB only. World's most advanced compositing software is leading the way.
I do stuff.
Offline

Frank Engel

  • Posts: 847
  • Joined: Thu May 17, 2018 11:09 pm
  • Real Name: Frank Engel

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostThu Mar 17, 2022 11:30 am

They are probably getting ready to introduce a beta channel as its replacement, but they haven't finished implementing it yet.

8-)
Offline

alan bovine

  • Posts: 145
  • Joined: Mon Aug 07, 2017 6:20 pm

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostThu Mar 17, 2022 5:59 pm

Fuzionmonger?
Fusion video tutorials : https://www.youtube.com/channel/UCTCeDas53OEcWcRujkQiwLg/videos?view_as=subscriber
Fusion Tools : https://github.com/statixVFX/stx_tools
Nuke 2 Fusion nodes : https://github.com/statixVFX/nuke2fusion
Offline
User avatar

Chad Capeland

  • Posts: 2859
  • Joined: Mon Nov 10, 2014 9:40 pm

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostFri Mar 18, 2022 3:29 pm

Hendrik Proosa wrote:Alpha channel is so 80-s, modern comping is RGB only. World's most advanced compositing software is leading the way.


You joke, but scalar alpha has no physical basis, it's only useful for data saving and vectorization. Absorption, the physical phenomenon alpha is trying to represent, would be more accurately represented with it's own RGB values.

Many 3D renderers already support this, but I don't know what compositing software supports it out of the box. Fusion has BgRGBA channel support, so making a plugin or fuse to do RGBRaBaGa compositing is certainly feasible in Fusion, assuming you don't mind carrying two vestigial alpha channels.
Chad Capeland
Indicated, LLC
www.floweffects.com
Offline

infinityespi

  • Posts: 36
  • Joined: Tue Nov 26, 2019 3:58 pm
  • Real Name: Eduardo Espinosa

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostFri Mar 18, 2022 5:16 pm

Reported this back in October lol. Take your fusion comp over to resolve and export as 444 with alpha in the delivery tab. That’s what I’ve been doing. Rendering to EXR is also a viable. Hopefully more people bother Blackmagic about it so I can just use fusion studio.
DaVinci Resolve Studio 17
macOS Big Sur
Imac 2021
M1
16 gigs of Ram
https://www.infinityespi.com
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostSat Mar 19, 2022 12:09 pm

Take your fusion comp over to resolve

:? Of course I guess everybody - including me now - change one's WF to cope with it...

Now I know, I'll obviously start - or import just before exporting - projects resulting in PR 4444 in ReFusion, sometimes it's just to make specific one layer file and stuff, but that's not acceptable at all imho.
Anyway thx for those who wrote serious inputs :|

(and btw : hints for an older Fusion version (though higher than 9.0.3) whose pr 4444 export would not be broken still appreciated if it exists)
*MacMini M1 16 Go - Ext nvme SSD
*Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches
*Resolve Studio everywhere, Fusion Studio too
*https://www.buymeacoffee.com/samalaplaya
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostTue Mar 29, 2022 2:52 pm

Obviously not fixed in 17.4.6

(And I think it's worst than I had checked, because it's not only it doesn't export the alpha channel in a PR 4444, but it also doesn't import these PR files which have correct alpha channel embedded... Thus a whole bunch of files I'd been given for years :cry: )
*MacMini M1 16 Go - Ext nvme SSD
*Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches
*Resolve Studio everywhere, Fusion Studio too
*https://www.buymeacoffee.com/samalaplaya
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostWed Apr 20, 2022 2:36 pm

Cannot test 18 so far : can someone confirm ProRes 4444 still doesn't either import or export its alpha channel correctly on the beta please ?
Didn't see any announce on the official changes.

If it's fixed (yes, dreams are free), I think it will be the first time I'll work on a beta :lol: :ugeek:
THX
*MacMini M1 16 Go - Ext nvme SSD
*Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches
*Resolve Studio everywhere, Fusion Studio too
*https://www.buymeacoffee.com/samalaplaya
Offline
User avatar

Philipp Walz

  • Posts: 341
  • Joined: Fri Apr 25, 2014 12:41 pm
  • Location: Borkwalde - Germany

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostWed Apr 20, 2022 3:01 pm

Sam Steti wrote:Cannot test 18 so far : can someone confirm ProRes 4444 still doesn't either import or export its alpha channel correctly on the beta please ?
Didn't see any announce on the official changes.

If it's fixed (yes, dreams are free), I think it will be the first time I'll work on a beta :lol: :ugeek:
THX


It's not!
Pete
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostWed Apr 20, 2022 3:02 pm

:cry: Really can't understand that...
*MacMini M1 16 Go - Ext nvme SSD
*Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches
*Resolve Studio everywhere, Fusion Studio too
*https://www.buymeacoffee.com/samalaplaya
Offline

PatrickFaith

  • Posts: 17
  • Joined: Fri Nov 14, 2014 4:00 pm

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostWed Apr 20, 2022 7:03 pm

This whole no alpha 4444 thing is just weird in that there is no official statement on it. On 18 i did notice two versions of prores 4444 ... one with a "hw" in the name. the prores without the "hw" actually crashed when i tried to do a 4444 with alpha write.
Offline
User avatar

Philipp Walz

  • Posts: 341
  • Joined: Fri Apr 25, 2014 12:41 pm
  • Location: Borkwalde - Germany

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostThu Apr 21, 2022 7:17 am

PatrickFaith wrote:This whole no alpha 4444 thing is just weird in that there is no official statement on it. On 18 i did notice two versions of prores 4444 ... one with a "hw" in the name. the prores without the "hw" actually crashed when i tried to do a 4444 with alpha write.


The hw stands for HARDWARE in my opinion because on ARM Macs you use the media engine, which is hardware based.
Pete
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostThu Apr 21, 2022 7:37 am

So can we rely on the statement that "a certain PR 4444 in the new version" (this hw one) exported from Fusion properly handles alpha channel ?
And therefore is also properly imported back in, showing no issue with this alpha channel ?
*MacMini M1 16 Go - Ext nvme SSD
*Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches
*Resolve Studio everywhere, Fusion Studio too
*https://www.buymeacoffee.com/samalaplaya
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostSat Apr 23, 2022 11:32 am

PatrickFaith wrote:This whole no alpha 4444 thing is just weird in that there is no official statement on it. On 18 i did notice two versions of prores 4444 ... one with a "hw" in the name. the prores without the "hw" actually crashed when i tried to do a 4444 with alpha write.

Ok, I ask again with less words : on 18, does ANY PR 4444 properly export and import its alpha channel please ?
*MacMini M1 16 Go - Ext nvme SSD
*Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches
*Resolve Studio everywhere, Fusion Studio too
*https://www.buymeacoffee.com/samalaplaya
Offline
User avatar

Tomek Kosiorek

  • Posts: 34
  • Joined: Wed Oct 28, 2015 11:14 am
  • Location: Warsaw

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostSat Apr 23, 2022 1:41 pm

I have rendered Pro Res 4444 with alpha. MacOS 10.14.6, Fusion Studio 18
Apple Mac Pro Late 2013, 64 GB RAM, 1TB SSD, 8TB LaCie RAID 0, Fusion Studio 17.4.6, Davinci Resolve Studio 16.2.8
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostSat Apr 23, 2022 3:34 pm

Hmmm, thx for your answer but it seems that Silicon Mac only were involved in this issue...
Thanks anyway.
I think i should hurry to end up my ongoing projects to test
*MacMini M1 16 Go - Ext nvme SSD
*Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches
*Resolve Studio everywhere, Fusion Studio too
*https://www.buymeacoffee.com/samalaplaya
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostSat Apr 23, 2022 4:20 pm

Ok, finally found a way to save v17 studio and render nodes apps safely to dl and try Fusion Studio 18. On a Mini M1 as you know...
I preyed hard but :

* it imports PR 4444 - which I know for sure they contain an alpha channel for I also retested them elsewhere before - but doesn't show this very alpha channel properly : as on 17, a black BG seems to be baked in. Of course, you can try any ticking (invert etc etc)

* it can export a PR 4444 AND the parameter "save alpha" has come back in the saver node when choosing PR 4444, but here also, it doesn't take the alpha into account. To wipe any possibility of mistake, I even tried exporting a PSD file (which here shows its alpha channel in the viewer) but no, black BG baked in as if you had ticked "make alpha solid"

In any case, no way to see the grey checkerboard I chose Fusion to show in the viewer for alpha, so I knew it wouldn't work (the PSD showed it properly for example)

=> back to 17 and still no option to import and use all these PR 4444 holograms I've been given to work with in my ongoing project :roll:
*MacMini M1 16 Go - Ext nvme SSD
*Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches
*Resolve Studio everywhere, Fusion Studio too
*https://www.buymeacoffee.com/samalaplaya
Offline

PatrickFaith

  • Posts: 17
  • Joined: Fri Nov 14, 2014 4:00 pm

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostSat Apr 23, 2022 4:37 pm

Sam Steti wrote:Ok, finally found a way to save v17 studio and render nodes apps safely to dl and try Fusion Studio 18. On a Mini M1 as you know...
I preyed hard but :

* it imports PR 4444 - which I know for sure they contain an alpha channel for I also retested them elsewhere before - but doesn't show this very alpha channel properly : as on 17, a black BG seems to be baked in. Of course, you can try any ticking (invert etc etc)

* it can export a PR 4444 AND the parameter "save alpha" has come back in the saver node when choosing PR 4444, but here also, it doesn't take the alpha into account. To wipe any possibility of mistake, I even tried exporting a PSD file (which here shows its alpha channel in the viewer) but no, black BG baked in as if you had ticked "make alpha solid"

In any case, no way to see the grey checkerboard I chose Fusion to show in the viewer for alpha, so I knew it wouldn't work (the PSD showed it properly for example)

=> back to 17 and still no option to import and use all these PR 4444 holograms I've been given to work with in my ongoing project :roll:

I have given up trying to get the alpha to work, i tend to now convert a 4444 to either two files (move the alpha to rgb on another prores file), or just bite the bullet and convert the entire 4444 file to openexr folder.
Online
User avatar

roger.magnusson

  • Posts: 2568
  • Joined: Wed Sep 23, 2015 4:58 pm

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostSat Apr 23, 2022 5:49 pm

Judging from a quick google search it seems it's something that Apple needs to fix on the M1 and nothing BMD can do about it unless they can encode in software only.
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostSun Apr 24, 2022 3:24 pm

roger.magnusson wrote:it's something that Apple needs to fix on the M1

That's what I finally concluded, since one single Fusion version (therefore with codes for x86 & silicon) doesn't show same results on different OS versions
*MacMini M1 16 Go - Ext nvme SSD
*Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches
*Resolve Studio everywhere, Fusion Studio too
*https://www.buymeacoffee.com/samalaplaya
Offline

Hendrik Proosa

  • Posts: 2397
  • Joined: Wed Aug 22, 2012 6:53 am
  • Location: Estonia

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostSun Apr 24, 2022 6:23 pm

This would mean that M1 is unable to write prores4444, which would in turn mean massive moaning in the internet related to other softwares too. Is this the case with FCP etc for example?
I do stuff.
Online
User avatar

roger.magnusson

  • Posts: 2568
  • Joined: Wed Sep 23, 2015 4:58 pm

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostSun Apr 24, 2022 6:53 pm

I found several threads about it in the Apple community forums.
Offline

Frank Engel

  • Posts: 847
  • Joined: Thu May 17, 2018 11:09 pm
  • Real Name: Frank Engel

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostMon Apr 25, 2022 9:09 am

There is an interesting comment on one of the Apple Developer forums that someone tested a few different pixel formats and found that 64ARGB works on Intel-based Macs but fails to work on Apple Silicon, but the opposite is true for 64RGBALE, which works on Apple Silicon but fails on Intel-based Macs.

Someone else reported that 4444AYpCbCr16 seems to work.

https://developer.apple.com/forums/thread/694622
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostMon Apr 25, 2022 9:24 am

Hey,
Nice from you to post the apple forum discussion on it, thank you.

We indeed see that the bug is very versatile... AND... I just read that :"Looks like MacOS Montery 12.3.1 updated the video codecs. Perhaps the problem is fixed.", posted 1 week ago.

My M1 is still on BigSur, but I don't mind upgrading the OS this time, so can someone confirm this ?
*MacMini M1 16 Go - Ext nvme SSD
*Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches
*Resolve Studio everywhere, Fusion Studio too
*https://www.buymeacoffee.com/samalaplaya
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostMon Apr 25, 2022 9:42 am

And besides all these remarks, how come we're told here above that on a same computer, pr4444 works correctly in Resolve Fusion ?
*MacMini M1 16 Go - Ext nvme SSD
*Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches
*Resolve Studio everywhere, Fusion Studio too
*https://www.buymeacoffee.com/samalaplaya
Offline

Hendrik Proosa

  • Posts: 2397
  • Joined: Wed Aug 22, 2012 6:53 am
  • Location: Estonia

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostMon Apr 25, 2022 10:33 am

Chad Capeland wrote:…scalar alpha has no physical basis, it's only useful for data saving and vectorization. Absorption, the physical phenomenon alpha is trying to represent, would be more accurately represented with it's own RGB values.

Many 3D renderers already support this, but I don't know what compositing software supports it out of the box. Fusion has BgRGBA channel support, so making a plugin or fuse to do RGBRaBaGa compositing is certainly feasible in Fusion, assuming you don't mind carrying two vestigial alpha channels.

As a small sidetrack this is interesting area. I would approach alpha as it stands now not as absorbtion, but as coverage. Because conceptually most of the practical physical applications also deal with absolute absorbtion but partial coverage: edge detail (object covers less than 100% of screen space pixel), motion blur (coverage modulated by time), out of focus blur (coverage modulated by divergence/convergence of light paths) etc. Absorbtion only comes to play with semitransparent and translucent objects, which make up a minority of situations. Most objects are, for practical purposes of imaging, solid and absorb all light (nothing passes through maintaining the direction of light path). Internal scattering within object isn’t something alpha should imho model, so this part of light transport seems unimportant in context of alpha, espectially since merging in 2d space is based on implicit assumption of consistent light path through objects on different layers (no refraction).
I do stuff.
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostTue Apr 26, 2022 7:17 am

Ok, any PR4444 which doesn't properly* imports its alpha channel in Fusion standalone 17 makes it happen correctly in Resolve's Fusion tab.
Any PR4444 exported from Fusion standalone 17 doesn't feature a proper* alpha channel when it's supposed to (visible in the viewer etc etc), while the same project exports it properly from Resolve's Fusion tab.

*the alpha channel is turned into a solid black

So I'm even more confused and less convinced by the only Apple Mx dev explanation, since the same mini M1 succeeds with ReFusion and fails with Fusion standalone on the same basic projects...
*MacMini M1 16 Go - Ext nvme SSD
*Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches
*Resolve Studio everywhere, Fusion Studio too
*https://www.buymeacoffee.com/samalaplaya
Offline
User avatar

Philipp Walz

  • Posts: 341
  • Joined: Fri Apr 25, 2014 12:41 pm
  • Location: Borkwalde - Germany

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostTue Apr 26, 2022 12:03 pm

I think AT LEAST there must be an official statement from Blackmagic! What do they know?
Pete
Offline

DBCreative

  • Posts: 18
  • Joined: Mon Jan 17, 2022 10:16 pm
  • Real Name: Danny Burns

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostSat Apr 30, 2022 5:35 am

Sam Steti wrote:Ok, any PR4444 which doesn't properly* imports its alpha channel in Fusion standalone 17 makes it happen correctly in Resolve's Fusion tab.
Any PR4444 exported from Fusion standalone 17 doesn't feature a proper* alpha channel when it's supposed to (visible in the viewer etc etc), while the same project exports it properly from Resolve's Fusion tab.

*the alpha channel is turned into a solid black

So I'm even more confused and less convinced by the only Apple Mx dev explanation, since the same mini M1 succeeds with ReFusion and fails with Fusion standalone on the same basic projects...


Also, though I wouldn't put it past Apple to F something like this up, this doesn't seem to be an issue in other, non BMD apps. For example, I can load, display and export PR 4444 files with a correct alpha from After Effects. Fusion Standalone can't import, display or export.
Offline
User avatar

Philipp Walz

  • Posts: 341
  • Joined: Fri Apr 25, 2014 12:41 pm
  • Location: Borkwalde - Germany

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostSat Apr 30, 2022 7:41 am

STATEMENT please!
Pete
Offline

Hendrik Proosa

  • Posts: 2397
  • Joined: Wed Aug 22, 2012 6:53 am
  • Location: Estonia

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostSat Apr 30, 2022 8:23 am

Philipp Walz wrote:STATEMENT please!

BMD never makes statements about bugs, it isn’t part of their philosophy to admit bugs.
I do stuff.
Online
User avatar

roger.magnusson

  • Posts: 2568
  • Joined: Wed Sep 23, 2015 4:58 pm

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostSat Apr 30, 2022 11:00 am

DBCreative wrote:For example, I can load, display and export PR 4444 files with a correct alpha from After Effects. Fusion Standalone can't import, display or export.

Is it known whether After Effects uses the M1 ProRes hardware acceleration or not?
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostSat Apr 30, 2022 11:19 am

DBCreative wrote:For example, I can load, display and export PR 4444 files with a correct alpha from After Effects. Fusion Standalone can't import, display or export.

Even Resolve's Fusion 17 or 18 works properly with that...
*MacMini M1 16 Go - Ext nvme SSD
*Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches
*Resolve Studio everywhere, Fusion Studio too
*https://www.buymeacoffee.com/samalaplaya
Offline

PatrickFaith

  • Posts: 17
  • Joined: Fri Nov 14, 2014 4:00 pm

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostSat Apr 30, 2022 3:42 pm

I tried all the pr 4444 alpha options on a mac studio with vs 18, none of them worked. Looks like bm is atleast trying with 2 versions of the 4444 avalaible on the save node.
Offline

DBCreative

  • Posts: 18
  • Joined: Mon Jan 17, 2022 10:16 pm
  • Real Name: Danny Burns

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostSun May 01, 2022 12:52 am

roger.magnusson wrote:
DBCreative wrote:For example, I can load, display and export PR 4444 files with a correct alpha from After Effects. Fusion Standalone can't import, display or export.

Is it known whether After Effects uses the M1 ProRes hardware acceleration or not?


I don't know, but AE is now optimized for the M1, so my guess would be a strong 'probably', but I could be wrong.
Offline
User avatar

Philipp Walz

  • Posts: 341
  • Joined: Fri Apr 25, 2014 12:41 pm
  • Location: Borkwalde - Germany

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostThu May 05, 2022 8:30 am

Hendrik Proosa wrote:BMD never makes statements about bugs, it isn’t part of their philosophy to admit bugs.


In my opinion a statement for an application which is used for VFX and rgba import/export would be very reasonable! This is a key task of this application and if this does not work, the app become unusable.

I did a quick test with Apple Motion and exported a ProRes4444 with alpha. I imported it back to Motion and the alpha was intact and correct. In Fusion, the alpha is just solid white.

So Fusion does not work correctly in this key task (handover ProRes4444 files from another artist a.s.o.) and I cannot work with these files anymore which makes 99% of my workflow. But Motion does! Maybe this is an Apple issue, but it seems to be more complex.

So a statement from the vendor of the not correctly working app would be useful.

I just found a thread from telestream where this issue might be fixed from them: https://telestreamforum.forumbee.com/t/83hj5sz/alpha-channel-in-prores-4444-quicktime-video-files-no-longer-works
Pete
Offline
User avatar

Philipp Walz

  • Posts: 341
  • Joined: Fri Apr 25, 2014 12:41 pm
  • Location: Borkwalde - Germany

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostThu May 05, 2022 8:38 am

In Resolve Fusion the Alpha import works correctly 18b2
Pete
Offline

Hendrik Proosa

  • Posts: 2397
  • Joined: Wed Aug 22, 2012 6:53 am
  • Location: Estonia

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostThu May 05, 2022 10:33 am

Philipp Walz wrote:
Hendrik Proosa wrote:BMD never makes statements about bugs, it isn’t part of their philosophy to admit bugs.


In my opinion a statement for an application which is used for VFX and rgba import/export would be very reasonable!

It would require the ”philosophy” to be reasonable and oriented on professional user. There aren’t many signs to indicate this, rather quite the opposite.
I do stuff.
Offline
User avatar

Philipp Walz

  • Posts: 341
  • Joined: Fri Apr 25, 2014 12:41 pm
  • Location: Borkwalde - Germany

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostThu May 05, 2022 12:08 pm

Hendrik Proosa wrote:It would require the ”philosophy” to be reasonable and oriented on professional user. There aren’t many signs to indicate this, rather quite the opposite.


I wouldn't totally agree on that but I don't like the way standalone Fusion is treated by Blackmagic. Most of the good stuff from Resolve (OFX plugins, alpha import/export etc.) is not integrated but the Resolve version lacks performance against standalone.

Very frustrating.
Pete
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostThu May 05, 2022 3:15 pm

Philipp Walz wrote:In Resolve Fusion the Alpha import works correctly 18b2

I keep an eye on this thread just to hopefully read a new beta version does, and read log changes of new versions to hopefully read this fix is included in every last beta...

Anyway, for those who got crazy - like me - and wish to make a bunch of tests on various apps on various projects and files, I'd suggest not to waste your time : who better than BMD could find and fix the issue when you know that EVERYTHING WORKS NORMALLY IN RESOLVE'S FUSION TAB :geek:

Edit : imho it's far beyond frustration
*MacMini M1 16 Go - Ext nvme SSD
*Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches
*Resolve Studio everywhere, Fusion Studio too
*https://www.buymeacoffee.com/samalaplaya
Offline
User avatar

Philipp Walz

  • Posts: 341
  • Joined: Fri Apr 25, 2014 12:41 pm
  • Location: Borkwalde - Germany

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostThu May 05, 2022 3:19 pm

Sam Steti wrote:who better than BMD could find and fix the issue when you know that EVERYTHING WORKS NORMALLY IN RESOLVE'S FUSION TAB


Performance -> time -> money
Pete
Offline

Sam Steti

  • Posts: 1879
  • Joined: Tue Jun 17, 2014 7:29 am
  • Location: France

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostThu May 05, 2022 3:27 pm

I'm not to be convinced man...

I have 700+ PR4444 with alpha waiting to be processed in a new project, believe me I'm down in the dumps
*MacMini M1 16 Go - Ext nvme SSD
*Legacy MacPro 8core Xeons, 32 Go ram, 2 x gtx 980 ti, 1SSD for system, 2 SSDs raid0 for footage and caches
*Resolve Studio everywhere, Fusion Studio too
*https://www.buymeacoffee.com/samalaplaya
Offline
User avatar

Philipp Walz

  • Posts: 341
  • Joined: Fri Apr 25, 2014 12:41 pm
  • Location: Borkwalde - Germany

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostThu May 05, 2022 3:29 pm

Sam Steti wrote:I'm not to be convinced man...

I have 700+ PR4444 with alpha waiting to be processed in a new project, believe me I'm down in the dumps


Absolutely! This is not a simple bug. This is essential!
It's like "Oh, I can't see a picture in the viewer"

It makes the app useless for people working with alpha channel loaders and it has to be fixed NOW. Period.
Pete
Offline
User avatar

AlexYez

  • Posts: 46
  • Joined: Tue Apr 21, 2020 5:20 pm
  • Location: Planet Earth
  • Real Name: Alexander Ezhov

Re: Whaaaattt !??!! No alpha exported in ProRes 4444 !

PostFri May 06, 2022 11:19 am

Fusion Studio 17.4.6 on Windows, prores 4444 and alpha ok
Attachments
KFTa0xE9jk.png
KFTa0xE9jk.png (354.04 KiB) Viewed 13767 times
Alexander Ezhov,
Compositing Artist, Davinci Resolve Certified Trainer
Next

Return to Fusion

Who is online

Users browsing this forum: No registered users and 9 guests