Page 1 of 1

Linux Install/Dependencies

PostPosted: Thu Apr 11, 2019 2:45 am
by MikeRochefort

At any point that's convenient (preferably before Fusion 16 Studio GA), would you guys mind adding the list of actual dependencies to the Linux installer or online manual? The installer itself can't run without some libraries (so far I have fuse-libs and libglvnd*, but I can't get past the following error:

Code: Select all
$ /opt/bmd/ --install --noconfirm
This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: xcb.

Reinstalling the application may fix this problem.

So far I've been testing in a container and the solution I've come up with was installing the GNOME Desktop group, which is not something I'm going to do on fresh render nodes. Installing qt5-base and qt5-qtx11extras does not solve anything, and installing all of the xcb packages available in the base repos doesn't do anything either. Going to try in a VM next.

It would be nice if you guys could possibly throw us a bone here with the bare minimum packages required to install (running is easily solvable). It would also be an small miracle if the software could be packaged in an RPM with all the dependencies nicely linked up ;) Side question, what udev rules are you changing?

Also, you detect if Python is available on the system and install your module in /usr/lib/pythonX.y. On RHEL the appropriate location is /usr/lib64/pythonX.y. Better yet would be to not touch that and just have Fusion add the location of that file to the PYTHONPATH when the Fusion executable is run.


Re: Linux Install/Dependencies

PostPosted: Thu Apr 11, 2019 4:07 am
by MikeRochefort
Completely disregard the above post, it was an issue with containers. Worked just fine from a minimal install of C7 and adding fuse-libs/libglvnd*. Fusion itself will obviously need more than that.

The Python point still stands, though ;)


Re: Linux Install/Dependencies

PostPosted: Tue Jul 28, 2020 3:46 am
by ericheder
I just bumped into this issue myself and found this post.

Eventually figured out, it happened when I ran the render node installer with sudo on a fresh install of Linux (actually LinuxMint 20.4 in my case). After running the installer as user and entering the superuser password in the window popping up, everything works fine.

Just mentioning in case someone else runs into this problem and finds this thread.