BM Ultrastudio 4K Device not detected

Do you have questions about Desktop Video, Converters, Routers and Monitoring?
  • Author
  • Message
Offline

MichelleSTC

  • Posts: 7
  • Joined: Wed Jun 26, 2019 2:43 am
  • Real Name: Michelle St Claire

BM Ultrastudio 4K Device not detected

PostSun Mar 08, 2020 9:27 am

Hey there,

I've been having a problem with a Blackmagic 4k (the TB2 Rackmount version) where it seems unable to be detected by Desktop Video under any circumstances. I tested a variety of aspects, including daisy chaining through to a monitor to see if it was receiving data, which worked, the device shows up in the system report, and on all iterations my older Mini Monitor shows up fine in Desktop Video.

I've currently tried it on 2 different computers, both running MacOs 10.15.3, then on a third system running a fresh install of 10.14. I've tried uninstalling the drivers and reinstalling Desktop Video. I tried that with 11.5, 11.4.1, 10.7, and 9.5, just to see if an older version would work but all of them had the same results (miniMonitor works, 4k doesn't). I know there's 'security' preferences, but not only have I pressed allow on everything in the security preferences, I don't know how that would interact with one device and not the other

I've contacted the original owner who swears up and down it worked on his system (and I believe him)

I'm reaching a point of not really knowing what other elements I can change to see what's up with the device and checking to see if there's any advice out there
Offline

Username

  • Posts: 167
  • Joined: Tue Jun 25, 2019 2:33 am
  • Real Name: Petter Flink

Re: BM Ultrastudio 4K Device not detected

PostWed Mar 11, 2020 5:14 am

When its connected to your Mac, is the Ultrastudio visible in the Thunderbolt tree under Systeminformation?
In case it's not visible there it might be a bad port, cable or something else that is causing the trouble and not the drivers.
Grew up with a Nikon FM - Evolving with a BMMCC
Resolve Studio 16.2.0.055 - Fusion Studio 16.2.22
Offline

MichelleSTC

  • Posts: 7
  • Joined: Wed Jun 26, 2019 2:43 am
  • Real Name: Michelle St Claire

Re: BM Ultrastudio 4K Device not detected

PostWed Mar 11, 2020 7:31 am

Yes it is visible in the System Information, which is part of why I've confused as to what I should do
Offline

Username

  • Posts: 167
  • Joined: Tue Jun 25, 2019 2:33 am
  • Real Name: Petter Flink

Re: BM Ultrastudio 4K Device not detected

PostWed Mar 11, 2020 2:48 pm

Is it visible under its full name and function?

I've found that sometimes a unit appears under Blackmagic name but as a generic type only.
Then the System have not identified it correctly.

If you disconnect the hardware.
Perform a full uninstall.
Reboot
Install the latest software.
Reboot.
Boot, login and then attach the hardware.


Thats how I have solved some BM hardware problem.
Otherwise I'm a bit out of ideas.
Grew up with a Nikon FM - Evolving with a BMMCC
Resolve Studio 16.2.0.055 - Fusion Studio 16.2.22
Offline

MichelleSTC

  • Posts: 7
  • Joined: Wed Jun 26, 2019 2:43 am
  • Real Name: Michelle St Claire

Re: BM Ultrastudio 4K Device not detected

PostWed Mar 11, 2020 10:56 pm

So in System information it seems appear with the full device name "UltraStudio 4K" and have an info breakdown

I tried uninstall, reboot, reinstall, reboot, and then connect and open and still it flags the message "No Desktop Video Device Detected". As usual, the Mini Monitor shows up when it's plugged in instead, so I'm still not sure what in particular is wrong with this device given it's previous history and there's no way to manually control the device in any way
Offline

Username

  • Posts: 167
  • Joined: Tue Jun 25, 2019 2:33 am
  • Real Name: Petter Flink

Re: BM Ultrastudio 4K Device not detected

PostThu Mar 12, 2020 1:40 am

Which model of Mac do you have it connected to?
A thunderbolt 3 equipped Mac?
Is it connected with a thunderbolt 3 cable to the thunderbolt3 connector on the ultra studio?
It should be visible in the thunderbolt 3 tree in system information.

Make sure it’s not connected to the usb-c port on the ultra studio.
Grew up with a Nikon FM - Evolving with a BMMCC
Resolve Studio 16.2.0.055 - Fusion Studio 16.2.22
Offline

MichelleSTC

  • Posts: 7
  • Joined: Wed Jun 26, 2019 2:43 am
  • Real Name: Michelle St Claire

Re: BM Ultrastudio 4K Device not detected

PostThu Mar 12, 2020 2:17 am

I've tried it with both my newer 2019 iMac 5k, and with my older 2013 Mac Pro. The Mac Pro was through the thunderbolt 2 ports, and the newer is thunderbolt 3 with a 3-2 adaptor. There is no usb-c port on the device because the device is pre-usb-c. There's the 2 thunderbolt 2 ports on it.

I tried it on both machines with both MacOs10.14.1 Mojave, and Catalina 10.15.3, Neither of which worked, leading me to think it's not an OS issue
Offline

MichelleSTC

  • Posts: 7
  • Joined: Wed Jun 26, 2019 2:43 am
  • Real Name: Michelle St Claire

Re: BM Ultrastudio 4K Device not detected

PostThu Mar 12, 2020 2:17 am

sorry just to clarify, the device is the Ultrastudio 4k V2, the 1U rack mount version not the newer 4k Mini
Offline

Username

  • Posts: 167
  • Joined: Tue Jun 25, 2019 2:33 am
  • Real Name: Petter Flink

Re: BM Ultrastudio 4K Device not detected

PostThu Mar 12, 2020 5:55 am

Hmm OK.

If you launch Systeminformation and look in the left section under the Extensions.
Do you see three different Blackmagic extensions?
All being version 11.5 and signed?
Grew up with a Nikon FM - Evolving with a BMMCC
Resolve Studio 16.2.0.055 - Fusion Studio 16.2.22
Offline

MichelleSTC

  • Posts: 7
  • Joined: Wed Jun 26, 2019 2:43 am
  • Real Name: Michelle St Claire

Re: BM Ultrastudio 4K Device not detected

PostFri Mar 13, 2020 2:08 am

The three Blackmagic extensions I can see are
Blackmagic_Multibridge_Driver:

Version: 11.5
Last Modified: 19/2/20, 6:13 pm
Bundle ID: com.blackmagic-design.desktopvideo.multibridge.iokit.driver

BlackmagicIO:

Version: 11.5
Last Modified: 19/2/20, 6:13 pm
Bundle ID: com.blackmagic-design.driver.BlackmagicIO

BlackmagicUsbIO:

Version: 11.5
Last Modified: 19/2/20, 6:13 pm
Bundle ID: com.blackmagic-design.driver.BlackmagicUsbIO

All say Yes to Notarised and No to Loaded
Offline

DominicIrving

  • Posts: 17
  • Joined: Mon May 12, 2014 10:32 am

Re: BM Ultrastudio 4K Device not detected

PostThu Mar 26, 2020 10:00 am

Michelle, did you ever resolve this? I'm having a similar issue with an Ultrastudio 3D, although i have it working in MacOS (my Ultrastudio Player and recorder also work) but the Ultrastudio 3D is not seen in Windows Boot-camp (the other Ultrastudio devices are though) any help would be great
Offline

Username

  • Posts: 167
  • Joined: Tue Jun 25, 2019 2:33 am
  • Real Name: Petter Flink

Re: BM Ultrastudio 4K Device not detected

PostThu Mar 26, 2020 10:14 am

In the same Extension list you should find some DeckLink files as well.
DeckLink_Driver
DeckLink_File

And all should be 11.5
Otherwise I'm out of ideas for the moment.
Grew up with a Nikon FM - Evolving with a BMMCC
Resolve Studio 16.2.0.055 - Fusion Studio 16.2.22
Offline

DominicIrving

  • Posts: 17
  • Joined: Mon May 12, 2014 10:32 am

Re: BM Ultrastudio 4K Device not detected

PostThu Mar 26, 2020 1:03 pm

I've had a look in Windows Device manager and there is definitely a driver missing (other photo shows device manager with Ultrastudio recorder attached. Any idea what driver this is and where i would find it?

Ultrastudio_3D_1.jpg
with Ultrastudio Express 3D
Ultrastudio_3D_1.jpg (559.07 KiB) Viewed 31 times
Offline

DominicIrving

  • Posts: 17
  • Joined: Mon May 12, 2014 10:32 am

Re: BM Ultrastudio 4K Device not detected

PostThu Mar 26, 2020 1:04 pm

with Ultrastudio recorder


Ultrastudio_Recorder_1.jpg
Ultrastudio_Recorder_1.jpg (520.92 KiB) Viewed 31 times

Return to Post Production

Who is online

Users browsing this forum: No registered users and 8 guests