MacBook Air M1 & Ultrastudio Monitor 3g

Do you have questions about Desktop Video, Converters, Routers and Monitoring?
  • Author
  • Message
Offline

Tom Chase

  • Posts: 53
  • Joined: Fri Jan 17, 2014 12:04 am

MacBook Air M1 & Ultrastudio Monitor 3g

PostSat May 08, 2021 9:37 pm

Hi I recently got the Ultrastudio Monitor 3g for my Air - am getting message when using Resolve 17 that has me perplexed
"Failed to set videomode on the video I/O devices"

I have the devices attached directly to the MacBook Air and I am using an Apple Thunderbolt cable. Desktop video recognizes it and its currently set to 1080p 24 and I have had the same results with 1080p 23.987

I am running macOS Big Sur 11.3

Thanks for any help

Tommy
Offline

teak421

  • Posts: 12
  • Joined: Sun Dec 30, 2018 10:38 pm
  • Real Name: Michael Gaskin

Re: MacBook Air M1 & Ultrastudio Monitor 3g

PostThu Sep 16, 2021 5:27 pm

I am getting this same error... Did you ever figure it out? I followed the directions for M1 installation and still no worky.
Offline

teak421

  • Posts: 12
  • Joined: Sun Dec 30, 2018 10:38 pm
  • Real Name: Michael Gaskin

Re: MacBook Air M1 & Ultrastudio Monitor 3g

PostThu Sep 16, 2021 5:45 pm

System see's the device... see below.
Attachments
Screen Shot 2021-09-16 at 10.43.39 AM.png
Screen Shot 2021-09-16 at 10.43.39 AM.png (27.4 KiB) Viewed 357 times
Offline
User avatar

Mark Foster

  • Posts: 1129
  • Joined: Tue Oct 27, 2015 10:59 am
  • Location: austria - no kangaroos +g*

Re: MacBook Air M1 & Ultrastudio Monitor 3g

PostThu Sep 16, 2021 8:09 pm

EAMoore wrote:MY SOLUTION - UltraStudio Recorder 3G and Big Sur

Hello all. I had Desktop Video 11.7 installed on Catalina and then upgraded to Big Sur. I experienced the same issue as everyone else. The recorder was recognized, but all I saw was a black screen in OBS. I tried installing 12.0b1 and got the same thing. I completely uninstalled several times and reinstalled, but it was still the same.

Then I noticed that the uninstall left 3 kernal extensions on my system:
Blackmagic_Multibridge_Driver.kext
BlackmagicIO.kext
BlackmagicUsbIO.kext

So, I thought about getting rid of those. To do that, you have to boot into recovery mode, disable SIP, force delete the kernal extensions, then reenable SIP. Once I did all of this and then installed 12.0b1, it WORKED! Desktop Video recognizes the recorder and the picture displays correctly in OBS, using either SDI of HDMI.

Here were the steps I took:
1. Uninstall Video Desktop using the uninstall program.
2. Boot into Recovery Mode (command-r)
3. Open Terminal to disable SIP: At the prompt enter this command: csrutil disable
4. You will get a message that SIP has been disabled.
5. Then enter reboot.
6. Once you reboot, open Terminal and force delete the kernal extensions. In my case, the commands looked like this for the three extensions:
sudo rm -rf /Library/StagedExtensions/Library/Extensions/Blackmagic_Multibridge_Driver.kext
sudo rm -rf /Library/StagedExtensions/Library/Extensions/BlackmagicIO.kext
sudo rm -rf /Library/StagedExtensions/Library/Extensions/BlackmagicUsbIO.kext
7. After deleting the extensions, I rebooted in Recovery Mode (command-r)
8. Open Terminal to enable SIP: At the prompt enter this command: csrutil enable
9. Then enter reboot.
9. Once rebooted, install Video Desktop. I used the Beta, 12.0b1
10. If Desktop Video then says "No Desktop Device Detected" you have to go to System Preferences>Security & Privacy>General and the select "App Store and identified developers” and then “Allow” Blackmagic Design in the pop-up window. You might have to restart after that.

It worked for me, which made me think the leftover kernal extensions were the problem going from Catalina to Big Sur. I hope it works for you. I am glad to be back up and running with my 3G under Big Sur!
cMP 5.1 2x3,46/96GB/2x2TB 860pro/4x4TB HGST/SSD7101A 4x2TB 970evoplus/HP1344/BMD4k/Radeon VII
macOS 11.6.1

BMPCC 6k pro (7.3.1)
BMPCC 4k (7.3)+ MB speedbooster ultra 0.71 (3.60)
resolve studio 17.3.2
desktop video 12.1
intensity pro 4k

Return to Post Production

Who is online

Users browsing this forum: No registered users and 10 guests