eGPU Pro charging issues

Do you have questions about Desktop Video, Converters, Routers and Monitoring?
  • Author
  • Message
Offline

stunthamster

  • Posts: 2
  • Joined: Thu May 14, 2020 11:13 am
  • Real Name: Mike Duffy

eGPU Pro charging issues

PostThu May 14, 2020 11:18 am

Hey Folks;

I've got an eGPU pro which I'm connecting a new 2020 13" MacBook Pro to. It seems the eGPU is unable to charge this laptop for some reason. When plugged in, it shows as connected, and having power, but is not charging: See snippet from the System Report below:

Code: Select all
AC Charger Information:

  Connected:   Yes
  ID:   0x0000
  Wattage (W):   79
  Family:   0xe000400a
  Charging:   No


I've ensured the eGPU is updated to the latest version, 1.12, and is shows the following in the System Report:

Code: Select all
  Vendor Name:   Blackmagic Design
  Device Name:   eGPU Pro
  Vendor ID:   0x4
  Device ID:   0xA153
  Device Revision:   0x1
  UID:   0x0004109C4829AF00
  Route String:   1
  Firmware Version:   50.4


I've tried the usual things with the MBP, resetting SMC, PRAM etc, and it charges fine from a charger. Any ideas?
Online

Howard Roll

  • Posts: 673
  • Joined: Fri Jun 03, 2016 7:50 am

Re: eGPU Pro charging issues

PostSun May 17, 2020 10:24 am

If you swap out your charge cable with the TB3 you’re using for the eGPU does the laptop still charge?

That would isolate any cable issues to start.

Good Luck
Offline

MishaEngel

  • Posts: 1296
  • Joined: Wed Aug 29, 2018 12:18 am
  • Real Name: Misha Engel

Re: eGPU Pro charging issues

PostSun May 17, 2020 12:53 pm

1 extra cable and it works even when the eGPU is not attached.
Offline

stunthamster

  • Posts: 2
  • Joined: Thu May 14, 2020 11:13 am
  • Real Name: Mike Duffy

Re: eGPU Pro charging issues

PostMon May 18, 2020 10:51 am

Yup, looks like a cable issue - swapped it out, and now volts appear to be flowing with wild abandon into the laptop!

Cheers for the tips/help folks.

Return to Post Production

Who is online

Users browsing this forum: No registered users and 16 guests