Avid MC 2021 + Ultrastudio 4K Extreme

Do you have questions about Desktop Video, Converters, Routers and Monitoring?
  • Author
  • Message
Offline
User avatar

Chad Smith

  • Posts: 80
  • Joined: Wed Jun 05, 2013 1:48 am
  • Location: Kingston NY

Avid MC 2021 + Ultrastudio 4K Extreme

PostMon Feb 22, 2021 9:54 pm

Jumping back into Avid after many years. Running MC 2021.2.0 on a 2019 Mac Pro with Ultrastudio 4K Extreme TB2. This setup works fine with R17. However I am not seeing a way to enable the hardware inside MC. The docs for the BMD I/O say works with Avid.

How does one enable hardware on MC 2021? When I click the hardware icon in the timeline I just get audio no video regardless if it is enabled or not.
HP z820 Dual 12 Core - 128 Gig RAM - 1080ti - UltraStudio 4K Extreme - 32TB TB2 RAID - Flanders DM-250
Offline
User avatar

Glenn Sakatch

  • Posts: 461
  • Joined: Sat Apr 13, 2013 5:36 pm

Re: Avid MC 2021 + Ultrastudio 4K Extreme

PostSat Mar 06, 2021 4:47 pm

You may have to reinstall desktop video. I think it needs to be installed after Avid. I think I've hit an order of operations like this before.
Offline

Steve Fishwick

  • Posts: 209
  • Joined: Wed Mar 11, 2015 11:35 am

Re: Avid MC 2021 + Ultrastudio 4K Extreme

PostSun Mar 07, 2021 11:19 am

Right-click the hardware icon and make sure it is set to the BMD device, not NDI, or something else. And as mentioned make sure DVT is installed after Avid so it know where to put the drivers. Ultrastudio 4K Mini with MC 2021.2 and DVT v.12 working fine here.

Return to Post Production

Who is online

Users browsing this forum: No registered users and 4 guests