Desktop 12.0 Video Bug for MacOS on M1

Do you have questions about Desktop Video, Converters, Routers and Monitoring?
  • Author
  • Message
Offline

Martin Jones

  • Posts: 31
  • Joined: Wed Sep 14, 2016 7:46 pm

Desktop 12.0 Video Bug for MacOS on M1

PostTue Sep 21, 2021 7:51 pm

I'm going to update to 12.1 asap to see if they've fixed this bug, but I wanted to post this here because "BMD support" won't listen to me and basically called me a liar...

I have a DeckLink Quad 2 in a Sonnet Tech Thunderbolt 3 chassis.

Windows over Thunderbolt 3, works perfectly fine.

MacOS x86 over Thunderbolt 3, works perfectly fine.

MacOS M1 over Thunderbolt 3 on a M1 Mini, causes random kernel panics with a hard reset.

Same chassis, tested with several computers from Dell and Apple. Works perfectly in every situation except for the M1 Mini. So there is a bug in the M1 / ARM driver, but "support" doesn't believe me. Despite me explaining the situation several times, he insists that there is "an issue with my motherboard" and to contact the computer manufacturer. I keep explaining that there is no motherboard in this situation, but he ignores me.
Offline
User avatar

Uli Plank

  • Posts: 22458
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: Desktop 12.0 Video Bug for MacOS on M1

PostWed Sep 22, 2021 7:08 am

This may be connected with the issue that Apple is not supporting eGPUs any more on the M1 machines.
So, the ball might be in their field.
Now that the cat #19 is out of the bag, test it as much as you can and use the subforum.

Studio 18.6.6, MacOS 13.6.7, 2017 iMac, 32 GB, Radeon Pro 580
MacBook M1 Pro, 16 GPU cores, 32 GB RAM
Sonoma 14.5 with 19b3 (sandbox)
SE, UltraStudio Monitor G3
Offline

Martin Jones

  • Posts: 31
  • Joined: Wed Sep 14, 2016 7:46 pm

Re: Desktop 12.0 Video Bug for MacOS on M1

PostThu Sep 23, 2021 7:47 pm

But a DeckLink isn't an eGPU, it's a capture board.
Offline
User avatar

Uli Plank

  • Posts: 22458
  • Joined: Fri Feb 08, 2013 2:48 am
  • Location: Germany and Indonesia

Re: Desktop 12.0 Video Bug for MacOS on M1

PostThu Sep 23, 2021 9:31 pm

Yes, but it's connected by a chassis that's regularly used for eGPUs.
Now that the cat #19 is out of the bag, test it as much as you can and use the subforum.

Studio 18.6.6, MacOS 13.6.7, 2017 iMac, 32 GB, Radeon Pro 580
MacBook M1 Pro, 16 GPU cores, 32 GB RAM
Sonoma 14.5 with 19b3 (sandbox)
SE, UltraStudio Monitor G3

Return to Post Production

Who is online

Users browsing this forum: No registered users and 9 guests