Page 1 of 1

Decklink mini monitor 4K Randomly Disconnecting

PostPosted: Sun Oct 17, 2021 9:22 pm
by LayneWilson
Problem with Decklink mini monitor 4K
I have been using the Decklink mini monitor to send an HDR signal through HDMI to my ProArtPA32 for HDR color grading for the past two months. Everything works until it doesn’t. randomly the mini monitor 4K will stop being detected by my computer, giving the error “No Desktop Video Device detected”
No Desktop Video Device Detected.PNG
No Desktop Video Device Detected.PNG (245.92 KiB) Viewed 1336 times

This happens multiple times a day during an 8-hour color grading session. I can occasionally get it to reconnect by just restarting my computer. Still, the only way I have found to fix it temporarily guaranteed is by deleting the Desktop video program, reinstalling it then restarting the computer. I have been wasting hours of my day for the past couple of weeks doing this process.
Any advice on how to stop this from happening permanently?

Thanks, Layne

My system:
Win 10 64 bits
Z490 AORUS XTREME
Intel Core i9-10900K
128 GB DDR4 RAM
MSI RTX 3090 with NVIDIA studio driver 472.12
Resolve Studio 17.2.2
Desktop Video 12.1
Asus ProArt PA32UCX 32”

Re: Decklink mini monitor 4K Randomly Disconnecting

PostPosted: Mon Oct 18, 2021 8:05 pm
by Andrew Kolakowski
Re-set card in the motherboard or change PCI-E slot. Update motherboard drivers. Make sure PCI-E port resource are sufficient. Turn off antivirus software if you have one. If you use overclocking (CPU, RAM etc.) then put it back to standard speeds.
Clean up BM drivers with some 3rd party tools. Install not latest version, but an older one from 1 major version below, so if current is eg. 12.1 then install last 11.X version.
Re-install Resolve. If you can borrow different card- maybe yours is simply dying. There is somewhere here procedure how to re-initialise BM card, so as last resort try this. If no go sent on warranty or buy new one :D

Re: Decklink mini monitor 4K Randomly Disconnecting

PostPosted: Thu Nov 25, 2021 10:45 pm
by LayneWilson
Pretty sure my 3090 fried it felt the deck link and I t burnt my hand. Got a new one haven't been having this problem anymore.


Sent from my iPhone using Tapatalk