Resolve Database Manager Error

Do you have questions about Desktop Video, Converters, Routers and Monitoring?
  • Author
  • Message
Offline

Glitch

  • Posts: 1
  • Joined: Fri Aug 24, 2012 8:03 pm

Resolve Database Manager Error

PostFri Aug 24, 2012 8:14 pm

Just installed Resolve Lite on MacBook Pro Retina | OS X 10.8.1
When I want to create first initial database I get this error:

Error
Failed to open database connection: could not connect to server: Connection refused
Is the server running on host "127.0.0.1" and accepting

Tried to uninstall and install again.
No success!

Any ideas?

Glitch
Offline
User avatar

rick.lang

  • Posts: 13409
  • Joined: Wed Aug 22, 2012 5:41 pm
  • Location: Victoria BC Canada

Re: Resolve Database Manager Error

PostSat Aug 25, 2012 9:37 pm

Have you tried after rebooting the computer? That may help.

Is this your first install of Resolve on the computer? Are you installing Resolve 8.2.2 or the latest Resolve 9 beta? When you load Resolve, do you see the screen to select the account (Admin or Guest)? Can you click on the + sign in the bottom left corner? Just looking for more detail at what point it fails.
Rick Lang
Offline

CaptainHook

Blackmagic Design

  • Posts: 1680
  • Joined: Wed Aug 22, 2012 4:50 am
  • Location: Melbourne, Australia
  • Real Name: Hook

Re: Resolve Database Manager Error

PostWed Aug 29, 2012 8:57 pm

On some machines we've seen the database installation fail, and this causes the database to not start up properly.

A fix for this requires a few command for you to type on the terminal. This will uninstall the database, so the next install of Resolve will install it properly.

Before you run these it's important to make sure you don't have any data or resolve projects saved in your postgres database.

1) Stop the server
sudo /sbin/SystemStarter stop postgresql-8.4
2) Remove menu shortcuts:
sudo rm -rf /Applications/PostgreSQL 8.4
3) Remove the ini file
sudo rm -rf /etc/postgres-reg.ini
4) Removing Startup Items
sudo rm -rf /Library/StartupItems/postgresql-8.4
5) Remove the data and installed files
sudo rm -rf /Library/PostgreSQL/8.4
6) Delete the user postgres
sudo dscl . delete /users/postgres

Now, re-install Resolve, reboot, and then start Resolve.
**Any post by me prior to Aug 2014 was before i started working for Blackmagic**

Return to Post Production

Who is online

Users browsing this forum: No registered users and 5 guests