UltraStudio 4K and Thunderbolt connection issue

Do you have questions about Desktop Video, Converters, Routers and Monitoring?
  • Author
  • Message
Offline

DerekCooper

  • Posts: 102
  • Joined: Thu Sep 19, 2013 10:20 pm

UltraStudio 4K and Thunderbolt connection issue

PostWed Aug 31, 2016 2:10 pm

Hey,

We updated to a new machine and are no longer able to connect to the UltraStudio 4K device - current configuration:

Asus X99-Deluxe II motherboard
Asus ThunderboltEX 2 Thunderbolt card
Desktop Video 10.7.1
Thunderbolt 16.1.47.275 driver from Intel

We can still connect to our Promise Pegasus2 RAID arrays, so we know the Thunderbolt card is fine. We can *see* the UltraStudio 4K in the Thunderbolt Attached Devices dialog, connection status is *connected* but we still can't access the device.

Device Manager shows the device, but it's got the exclamation mark suggesting there is a problem.

Has anyone else run up against this issue? Guessing it will become an issue as people start adopting the newer Thunderbolt 3 hardware and upgrade their Thunderbolt drivers.

Thanks!

Derek
Offline

Adam Simmons

  • Posts: 5510
  • Joined: Thu Apr 04, 2013 4:21 pm
  • Location: UK

Re: UltraStudio 4K and Thunderbolt connection issue

PostWed Aug 31, 2016 3:35 pm

What version of Windows are you using? If you are using a clean install of the anniversary build of Windows 10 and your system has secure boot enabled in the BIOS then the BM drivers won't work as they aren't digitally signed by Microsoft, only digitally signed by BM.

If you open up the driver tab then it should give an indication of what the error is
DVC Built Clevo P775DM3-G Laptop with UHD screen, 7700K CPU@4.9Ghz, Geforce GTX 1060 6GB GPU, G-Sync UHD screen, 500GB M.2 Primary, 1x 480GB SSD, 1x1TB M.2, 1x 2TB Video drives.
Building Bespoke Video Editing systems for over 16 years
Offline

DerekCooper

  • Posts: 102
  • Joined: Thu Sep 19, 2013 10:20 pm

Re: UltraStudio 4K and Thunderbolt connection issue

PostWed Aug 31, 2016 5:11 pm

Interesting.

You're likely right - so disable the secure boot in the BIOS and we're golden?
Offline

Adam Simmons

  • Posts: 5510
  • Joined: Thu Apr 04, 2013 4:21 pm
  • Location: UK

Re: UltraStudio 4K and Thunderbolt connection issue

PostWed Aug 31, 2016 5:38 pm

I'm not sure if you can just disable it without re-installing Windows as I never use it on any systems here so all mine are installed with it already disabled as that's the default setting in the BIOS. I suppose the only thing you can do is try disabling it and see what happens
DVC Built Clevo P775DM3-G Laptop with UHD screen, 7700K CPU@4.9Ghz, Geforce GTX 1060 6GB GPU, G-Sync UHD screen, 500GB M.2 Primary, 1x 480GB SSD, 1x1TB M.2, 1x 2TB Video drives.
Building Bespoke Video Editing systems for over 16 years
Offline

DerekCooper

  • Posts: 102
  • Joined: Thu Sep 19, 2013 10:20 pm

Re: UltraStudio 4K and Thunderbolt connection issue

PostWed Aug 31, 2016 6:20 pm

Adam - I totally owe you some beers! You were absolutely right - the BM driver wasn't digitally signed by Microsoft so was prevented from being activated.

You don't have to re-install the OS, just disable driver signature verification in Windows startup - how-to right here:

http://goo.gl/lhqbdR

Nothing to change in the BIOS.

BM - perhaps get the drivers signed by Microsoft? ;)
Offline

Adam Simmons

  • Posts: 5510
  • Joined: Thu Apr 04, 2013 4:21 pm
  • Location: UK

Re: UltraStudio 4K and Thunderbolt connection issue

PostWed Aug 31, 2016 6:31 pm

They are intending to, but I assume they have to wait for Microsoft to check it then issue the certificate. Also bear in mind this will have to be done for every driver going forward so it may cause a delay on driver releases
DVC Built Clevo P775DM3-G Laptop with UHD screen, 7700K CPU@4.9Ghz, Geforce GTX 1060 6GB GPU, G-Sync UHD screen, 500GB M.2 Primary, 1x 480GB SSD, 1x1TB M.2, 1x 2TB Video drives.
Building Bespoke Video Editing systems for over 16 years
Offline

DerekCooper

  • Posts: 102
  • Joined: Thu Sep 19, 2013 10:20 pm

Re: UltraStudio 4K and Thunderbolt connection issue

PostFri Sep 09, 2016 1:14 pm

I see Desktop Video 10.8 was released today - hopefully the digitally signed driver is included?
Offline

Adam Simmons

  • Posts: 5510
  • Joined: Thu Apr 04, 2013 4:21 pm
  • Location: UK

Re: UltraStudio 4K and Thunderbolt connection issue

PostFri Sep 09, 2016 1:47 pm

On the driver tab it still says 'Blackmagic Design Pty Ltd' so not sure if it is or not
DVC Built Clevo P775DM3-G Laptop with UHD screen, 7700K CPU@4.9Ghz, Geforce GTX 1060 6GB GPU, G-Sync UHD screen, 500GB M.2 Primary, 1x 480GB SSD, 1x1TB M.2, 1x 2TB Video drives.
Building Bespoke Video Editing systems for over 16 years

Return to Post Production

Who is online

Users browsing this forum: No registered users and 15 guests