Missing api-ms-win-core-libraryloader-l1-2-2.dll

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

KPrins

  • Posts: 1
  • Joined: Wed Apr 11, 2018 8:17 am
  • Real Name: Kees Prins

Missing api-ms-win-core-libraryloader-l1-2-2.dll

PostWed Apr 11, 2018 8:34 am

Uninstalled previous version of Resolve and installed DaVinci_Resolve_15.0b1_Windows.exe on Windows 8.1, 64-bits, x64-processor. GeForce GTX 770 GPU. Installations completes, but if I start Resolve I get the message: "Missing api-ms-win-core-libraryloader-l1-2-2.dll". Re-installation of Resolve does not change things. Microsoft states that this dll is not part of Windows and should be provided by the software supplier. I remember having a similar problem wit an earlier beta-version, witch was resolved in the production-version. Can you provide me with this dll?
Offline

Giancarlo

  • Posts: 1
  • Joined: Thu Apr 19, 2018 5:58 pm
  • Real Name: Giancarlo Ferreri

Re: Missing api-ms-win-core-libraryloader-l1-2-2.dll

PostThu Apr 19, 2018 7:54 pm

I have exactly the same issue on a Windows 8.1 computer.
I don't know where to get this .dll, some help would be appreciated.
Offline

Suhaib Siddiqi

  • Posts: 162
  • Joined: Thu Jun 02, 2016 2:42 am

Re: Missing api-ms-win-core-libraryloader-l1-2-2.dll

PostThu Apr 19, 2018 11:28 pm

Giancarlo wrote:I have exactly the same issue on a Windows 8.1 computer.
I don't know where to get this .dll, some help would be appreciated.


That is a Windows dll, you do not get it from anywhere. The problem could that the dll is not registered, or some bad application could have unregistered it. Also, a virus on your system could have unregistered.

First try from command line as Adminstrater regsrv32 Missing api-ms-win-core-libraryloader-l1-2-2.dll, then reboot to see if problem is solved.

Second method:
The fix is simple thankfully. All you need to do is copy a DLL file from the system32 folder of the Windows 7 installation to the root Windows10Upgrade folder.

Open c:\windows\system32\ using Explorer or another file manager.
Type "wimg" quickly to jump to the right file. Or, browse until you find the file wimgapi.dll this way.
Select wimgapi.dll, right-click on it, and select copy from the context menu.
Open c:\Windows10Update\
Right-click on the folder and select Paste.
Confirm that you want to replace the pasted DLL file with the existing one.
The process may require elevation. Accept the prompt as well.

More details here: https://www.ghacks.net/2018/01/03/fix-t ... ing-error/
Offline

montyfox

  • Posts: 1
  • Joined: Tue Jul 24, 2018 3:50 am
  • Real Name: Monty Fox

Re: Missing api-ms-win-core-libraryloader-l1-2-2.dll

PostTue Jul 24, 2018 3:53 am

I too am having this problem. I have Windows 8.1 64bit x64 based processor. Has anyone been able to resolve this? I'm not upgrading to Windows 10 so moving a DLL to an upgrade folder is not an option. Will Resolve 15 Beta even work on Windows 8.1? I'd really like to use this software but I'm not upgrading to Windows 10.

Thanks
Offline

Waterboy

  • Posts: 1
  • Joined: Wed Sep 12, 2018 6:56 pm
  • Real Name: keith lysyk

Re: Missing api-ms-win-core-libraryloader-l1-2-2.dll

PostWed Sep 12, 2018 7:00 pm

Hi, I found a solution that worked for me for Windows 8.1.



A DLL file in the DaVinci Resolve installation folder ( OpenCL.dll ) checks for a few things in addition to existence of the api-ms-win-core-libraryloader-l1-2-2.dll in the system folders.

api-ms-win-core-libraryloader-l1-2-2.dll is a windows 10 file so simply delete (or rename to OpenCL.dll.old in case you need it later) and you can get into the program.

Hope that helps people.

Cheers!
Offline

nantkathy

  • Posts: 1
  • Joined: Thu Oct 11, 2018 11:08 am
  • Real Name: kathy nant

Re: Missing api-ms-win-core-libraryloader-l1-2-2.dll

PostFri Oct 19, 2018 10:17 am

Hi,

I installed DaVinci Resolve 15. The installation is successful but I cannot open it.
The message showed System error !
" The program can't start because api-ms-win-core-libraryloader-1-2-1.dll is missing from your computer. Try reinstalling the program to fix this problem."
I tried to reinstalled so many times, but still cannot open it.

System Info :
Windows 8.1
64 bit Operating system.

Please advise !

Thank you in advance.

Return to DaVinci Resolve

Who is online

Users browsing this forum: dirk-pel, Google [Bot], Micha Clazing, Miguel Ibáñez, Mikael Bellina and 27 guests