DNxHR codec not working on CentOS

Get answers to your questions about color grading, editing and finishing with DaVinci Resolve.
  • Author
  • Message
Offline

Lance Braud

  • Posts: 45
  • Joined: Wed Jul 29, 2015 3:07 am

DNxHR codec not working on CentOS

PostSun Jun 10, 2018 10:30 pm

When I attempt to deliver a timeline using the DNxHR codec (mov or mxf container) Resolve locks up as soon as it starts to render and closes about 30 seconds later.

In the Media tab, in the media storage browser, if I browse to a directory with a dnxhr file I've encoded with ffmpeg, resolve hangs immediately and closes about 30 seconds later.

I see no related errors in the rollinglog.txt file. Is there another place to check?

Can someone else running Resolve Studio 15b4 on CentOS (or any linux distro) try exporting an dnxhr file and report here?
Resolve Studio v16b7 | Nvidia GTX 1070 v430.86 Studio | Win10 x64 | AMD TR-1950X 16G RAM
Offline

Chip.Murphy

  • Posts: 154
  • Joined: Wed Mar 08, 2017 5:59 pm

Re: DNxHR codec not working on CentOS

PostMon Jun 11, 2018 12:32 am

The dnx codecs do not work on AMD processors on the Linux versions of Resolve. They work fine on windows. Did my testing on a 1950x.
Offline

Lance Braud

  • Posts: 45
  • Joined: Wed Jul 29, 2015 3:07 am

Re: DNxHR codec not working on CentOS

PostMon Jun 11, 2018 1:17 am

Looking in resolve's lib directory I see a DNxHD.so. I believe avcodec/ffmpeg doesn't compile a separate library just for that, so that would mean resolve's library comes from somewhere else. That's probably from AVID's SDK (https://www.avid.com/static/resources/U ... /dnxhd.pdf) which provides a linux binary.

If that's so then someone needs to get AVID to update their binaries...
Resolve Studio v16b7 | Nvidia GTX 1070 v430.86 Studio | Win10 x64 | AMD TR-1950X 16G RAM

Return to DaVinci Resolve

Who is online

Users browsing this forum: David Cherniack, Frank Engel, Gerhard Riesenhuber, Google [Bot], MarteX and 97 guests