Problems with DeckLink Duo 2 & OBS

Questions about ATEM Switchers, Camera Converter and everything live!
  • Author
  • Message
Offline

ShaakDJ

  • Posts: 1
  • Joined: Sun May 02, 2021 1:05 pm
  • Real Name: Marius Wiese

Problems with DeckLink Duo 2 & OBS

PostSun May 02, 2021 1:15 pm

Hi there,

I've just recived my DeckLink Duo 2 on friday. Today I wanted to try setting up OBS with the camera and so on but I'm not able to get a video Signal from my DeckLink card.

The actual setup is as following:

Sony A5100 -> BlackMagic Micro Converter HDMI - SDI -> DeckLink Duo 2

The Micro Converter is set to SDI Level A for 1080p60 and both leds light up.

In the Desktop Video Setup for the DeckLink card I've set the connectors to SDI 1 - 4 without combining channels 1&2 and 3&4. Because in the future I've planned with four cameras.

If I now add a new Blackmagic Device in OBS I just get a black Screen on all four SDI channels. If I just add a normal Video Device and then selecting the Blackmagic inputs it also shows just a black screen.

Do I have to change something more in the Video Setup or do you may have other tipps for getting the signal to OBS?

EDIT:

After hours of testing I found out, that I'm able to get a video signal from the Sony A5100 to OBS, but only if I set the camera to HDMI-Output 1080i. Then the DeckLink card shows an input of 1080i50. If I change that camera settings to 1080p I return to my black screen. When I connect a second PC via HDMI Out to the Converter I am able to get a signal at 720p60 & 1080p30 but at 1080p50/60 I get a black screen too.. Im nearly to belive the Micro Converter is not able to do 1080p60 even it is noticed in the specs :(
If I connect the Sony cam directly to a monitor it shows an input at 1080p50.

Anyone with ideas? Would really appreciate it :)
Offline

Lakshmikant

  • Posts: 9
  • Joined: Wed Sep 22, 2021 12:19 pm
  • Real Name: Lakshmikant Shakya

Re: Problems with DeckLink Duo 2 & OBS

PostWed Sep 22, 2021 5:31 pm

i am using micro converter HDMI to SDI (Updated)and SDI to HDMI (Updated) from my camera to my display (OR recorder).
i am getting only 1080 50i, 720 50p, 1080 25p at the other end of 100 meter (328 Feet) sdi cable.

when i use 1 (3.2 Feet) meter to 10 meter (32 feet) sdi cable i get 1080 50p.
i have not 50 meter (165 Feet) sdi cable so i could not test to 50 meter sdi cable but...
i think it (1080 50p) will work only up to 50 meter (164 feet)

i am using Belden 1505F (it is a rg59 standard sdi cable) (a Very high quality 100 meter sdi cable with very high quality connector)

Please See Picture Here
https://e.pcloud.link/publink/show?code ... PggScbylD7
Offline

Lakshmikant

  • Posts: 9
  • Joined: Wed Sep 22, 2021 12:19 pm
  • Real Name: Lakshmikant Shakya

Re: Problems with DeckLink Duo 2 & OBS

Offline

Dave Del Vecchio

  • Posts: 1128
  • Joined: Mon Nov 25, 2013 10:25 am

Re: Problems with DeckLink Duo 2 & OBS

PostThu Sep 23, 2021 12:03 pm

You might want to try setting the Micro Converter to output 3G SDI Level B if you haven't already. In theory, the DeckLink Duo 2 should support Level A with recent firmware, but it wouldn't be the first time I've seen inconsistent behavior due to the 3G SDI Level used.

Also, you might want to try updating the firmware on the Micro Converter if you are not on the latest:
https://www.blackmagicdesign.com/suppor ... converters

I'm not sure whether you are using the original Micro Converter or the Micro Converter 3G, but there have been various converter-related updates to improve HDMI compatibility. The Micro Converter 3G model is still fairly new, so I wouldn't be surprised if it behaves different from the original with regard to some HDMI sources.
Offline

Lakshmikant

  • Posts: 9
  • Joined: Wed Sep 22, 2021 12:19 pm
  • Real Name: Lakshmikant Shakya

Re: Problems with DeckLink Duo 2 & OBS

PostThu Sep 23, 2021 4:34 pm

thankyou all for helping me

Return to Live Production

Who is online

Users browsing this forum: No registered users and 28 guests