PNG shows with white background

Questions about ATEM Switchers, Camera Converter and everything live!
  • Author
  • Message
Offline

ClaytonMoore

  • Posts: 157
  • Joined: Tue Mar 26, 2013 3:14 pm

PNG shows with white background

PostWed Jan 26, 2022 6:47 pm

Lower third transparency problem.

ATEM Mini Pro ISO
M1 Air
ATEM software 8.6.4
Current updated versions of all software.

PNG's created in photoshop with transparent background show as transparent perfectly in Resolve and FCP, even appear normal in the media pool of ATEM (software) but on the actual ATEM itself, it shows as a lower 3rd with a white background only.

One more thing, these work fine in a Tricaster as well.

Following the process outlined but must be overlooking something.

Separately just as an FYI - don't think its related:
The photoshop plugin for direct export wont work even though its in the right place. Photoshop and ATEM dont see each other.
Offline
User avatar

Mark Foster

  • Posts: 1661
  • Joined: Tue Oct 27, 2015 10:59 am
  • Location: austria - no kangaroos +g*

Re: PNG shows with white background

PostWed Jan 26, 2022 7:29 pm

have a look at this setting (pre multplied key - on or off)

Screenshot 2022-01-26 at 20.27.49.jpg
Screenshot 2022-01-26 at 20.27.49.jpg (15.25 KiB) Viewed 582 times
cMP 5.1 2x3,46/96GB/2x2TB SSD/4x4TB/7101A 4x2TB 970evo+/HP1344/BMD4k/RadeonVII
macOS 11.6.5
BMPCC 6k pro (7.5.1)
meike s35 cine 25mm, 35mm, 50mm, 75mm
resolve studio 17.4.6
mini panel
speed editor
desktop video 12.1
intensity pro 4k
atem extreme (8.6.1)
Offline

ClaytonMoore

  • Posts: 157
  • Joined: Tue Mar 26, 2013 3:14 pm

Re: PNG shows with white background

PostWed Jan 26, 2022 11:33 pm

I checked ......... Its just not working. The latest version of photoshop wont direct export as it cannot connect to the ATEM. Gone off the wheels a bit - guess I have more work to do. Sigh......
Offline

eMilty

  • Posts: 90
  • Joined: Mon Oct 22, 2018 9:54 pm
  • Location: The Netherlands
  • Real Name: Marco Miltenburg

Re: PNG shows with white background

PostFri Jan 28, 2022 9:19 am

The ATEM switcher doesn't work with PNG images that have transparency. Bad decision by BMD if you ask me as it's the default for transparancy on the web. They should just support importing transparent PNGs and convert them on the fly.

In order to get transparancy to work on an ATEM switcher you need an image with an premultiplied key. This is what the BMD Photoshop plugin creates for you when you export to the ATEM directly. There are two videos by PhotoJoseph on YouTube (
,
) that clearly explain the difference and shows you how to create an image with a premultiplied key manually.

For Photoshop the steps are:

1. Load the image with transparency into Photoshop.
2. Duplicate the layer
3. Create a new layer at the bottom and fill that entirely with a black color.
4. Select the bottom two layers (the transparent image and black fill layer) and press Ctrl-E (or Cmd-E on Mac).
5. Hold the Ctrl (Cmd on Mac) while clicking the thumbnail of the original layer with transparancy.
6. Select the newly created merged layer and from the menu select Layer -> Layer Mask -> Reveal Selection
7. Delete the layer with the original transparent image.
8. Save the image to a PNG with transparancy.
9 Load that image into the ATEM and make sure to enable the Pre Multiplied Key checkbox in the keyer.

PS: For some cases where you don't need semi transparency (e.g. shadows, gradients) a simple transparent PNG will work just fine as the black added in the above steps will not be visible.
Offline

ClaytonMoore

  • Posts: 157
  • Joined: Tue Mar 26, 2013 3:14 pm

Re: PNG shows with white background

PostFri Jan 28, 2022 5:46 pm

I figured it out and I'm good now. Once I fixed the communications issue between Photoshop and my ATEM, its all good!
Offline

ClaytonMoore

  • Posts: 157
  • Joined: Tue Mar 26, 2013 3:14 pm

Re: PNG shows with white background

PostFri Jan 28, 2022 6:41 pm


Return to Live Production

Who is online

Users browsing this forum: Bing [Bot] and 29 guests