ATEM Mini Pro - Stream problems

Questions about ATEM Switchers, Camera Converter and everything live!
  • Author
  • Message
Offline

Drumlife

  • Posts: 2
  • Joined: Fri May 15, 2020 10:22 am
  • Real Name: Jernej Narat

ATEM Mini Pro - Stream problems

PostFri May 15, 2020 10:55 am

Greetings.

I just get the new ATEM Mini Pro switcher and I have a problem with streaming.

I followed all the instructions to setup the stream (Facebook and Youtube) and when I start streaming on switcher, sign ON AIR is turned on but on timecode there is nothing happening and I don't get any video source on Facebook or Youtube. I tried on both platforms (FB, YT) and on MAC and PC software.

I have included a video with recording steps.


Does anybody have a clue what's wrong??

Thank you for your help.
Offline
User avatar

TijmenWolf

  • Posts: 16
  • Joined: Fri Sep 07, 2012 3:48 pm
  • Location: Hoofddorp, the Netherlands

Re: ATEM Mini Pro - Stream problems

PostFri May 15, 2020 5:09 pm

Looks like you dont have enough upload speed.
Try changing the video quality.
Editor | Camera | Color | Production

From the Netherlands
Offline

rogersuski

  • Posts: 183
  • Joined: Wed Aug 29, 2012 12:37 am

Re: ATEM Mini Pro - Stream problems

PostFri May 15, 2020 6:01 pm

Is the ATEM able to "see" the internet?
Offline

Bramstocker

  • Posts: 1
  • Joined: Sat May 16, 2020 7:38 am
  • Real Name: Lilian Cornelis

Re: ATEM Mini Pro - Stream problems

PostSat May 16, 2020 7:41 am

hye

I've the same problem. Do you have fix it ?

Best
Offline

Drumlife

  • Posts: 2
  • Joined: Fri May 15, 2020 10:22 am
  • Real Name: Jernej Narat

Re: ATEM Mini Pro - Stream problems

PostSat May 16, 2020 11:00 am

TijmenWolf wrote:Looks like you dont have enough upload speed.
Try changing the video quality.


I tried changing video quality and nothing different happened, also when CACHE:OK .

rogersuski wrote:Is the ATEM able to "see" the internet?

I thinks so. Is there some trick on PC how to do that? For mac there are settings how to grant permission but I didn't find anything for PC.
Offline

Jeff in Indiana

  • Posts: 2
  • Joined: Sat May 23, 2020 9:07 pm
  • Real Name: Jeff Stanton

Re: ATEM Mini Pro - Stream problems

PostSat May 23, 2020 9:11 pm

I have the similar issues, but I connect using an ethernet adapter to my laptop. When I try to stream, I get nothing. I have turned sharing on and still nothing. I'll probably call Black Magic if I can't get it to work.
Offline

damdam21

  • Posts: 1
  • Joined: Fri Jun 19, 2020 3:28 pm
  • Real Name: Damien FORT

Re: ATEM Mini Pro - Stream problems

PostFri Jun 19, 2020 3:35 pm

Bonjour,

J'ai exactement le même problème (voir la vidéo ci-dessus).
Avez vous trouvé une solution ? ça fait plusieurs jours : que je cherche moi aussi.
:cry:
Cordialement
Offline

pokorie

  • Posts: 1
  • Joined: Wed Jun 24, 2020 11:47 pm
  • Real Name: Pinghwa Okorie

Re: ATEM Mini Pro - Stream problems

PostWed Jun 24, 2020 11:50 pm

I'm having the same problem. I am connected via USB-C. Anyone find a solution yet?
Offline

Keith Eveland

  • Posts: 1
  • Joined: Thu Jun 25, 2020 11:32 pm
  • Real Name: Keith Eveland

Re: ATEM Mini Pro - Stream problems

PostThu Jun 25, 2020 11:49 pm

I was having same issue. I had the atem connected to laptop via the usb out and the laptop using wifi. Facebook live was not receiving the video feed from the atem.
FYI, I am using the ATEM software control. I made sure and used the setup software first before using atem.
So then I hooked the atem directly to the router via ethernet cable. I then found the atem on my network via the software. Then the magic started lol
Offline

msfelicio

  • Posts: 1
  • Joined: Wed Jul 22, 2020 8:34 pm
  • Real Name: Marcelo Felício

Re: ATEM Mini Pro - Stream problems

PostWed Jul 22, 2020 8:48 pm

Hi I'm having similar issues with the Atem mini Pro.

We were streaming church services normally for weeks, one day with no particular explanation we couldn't get to stream. The ON AIR started, but approximately with 1 minute of stream cache starts to grow.

We observed that in M/V the timer next to ON AIR stopped and we couldn't get switch the streaming off by pressing the off button on the panel or in the software. Video cutting works fine. We can only try stream again by unplugging the device form the outlet.

We tried changing the quality and just got to stream in the "Hiperdeck Low" quality. Even trying Streaming low medium and High, only at hiperdeck low it worked. Yesterday was the opposite, nothing worked but streaming low. Our network connection is fine. We have 200down/60up fiber link. Speed test show perfect connection and ping.

We are using atem DHCP directly connected to the ONT ("modem")

it seems to be a software issue, please help us BMD
Offline

Canyons

  • Posts: 65
  • Joined: Fri May 22, 2020 10:14 pm
  • Real Name: Charles Christopher

Re: ATEM Mini Pro - Stream problems

PostMon Jul 27, 2020 4:54 pm

I'm going to make some assumptions here, and some will likely disagree with some of my comments.

This sounds like what we have gone through. Wifi is not designed for video, recent updates have tried to fix this but it is still problematic. Then you throw in the unknown of people watching videos, and a couple hundred concurrent connections, during service with children playing gaming apps on their phones, wifi degrades fast and unpredictably. It does not matter what the ISP connection is when wifi breaks.

From what my church went through, and discussions I had with a number of professional networking folks, video over wifi is an art not a science. The is especially true in a church with a guest wifi network (Up to 200 people in a service for us, some with multiple devices) being shared with critical infrastructure. Maybe this does not apply to you, but hopefully others will find it useful.

This was the solution we implemented:

https://store.ui.com/collections/unifi- ... s/unifi-hd

Ubiquiti offers some other "thunderous" access points, but the radiation pattern of that one is ideal for worship center ceiling mount as its pattern is done. The other units have even patterns which includes up so as to service upper floors in a building, which is not what we were trying to do. We want all the energy down and a bit out to the sides. Ubiqiti gives full radiation pattern data.

Before the Mini Pro our goal was to be able to stream high quality internet content to up to 8 bible study classes while also providing members guest access for online bible services. The key here is the leaders have full access to the internet, all others are metered so they can't stream any videos (for example). In other words the leaders are at church to stream, nobody else is, everybody else has service to use online bible resources of their choosing and likely can check their emails accounts as well.

The unifi HD supports up to 4 separate networks with unique settings for each network. So I have a public guest network that supports (from memory) 1 mbs down and 256 mbs up per user, the public gets clamped down HARD to just use what they should be using in church. If they dont like it, then they can use their cell service. This may sound harsh but we need the network to do what it is there for and not beyond that. Then there is another network for the leaders which is unlimited access. This part of the building is about 100 feet in diameter with the worship center on the upper floor and classes in the lower floor. There is about 3.0 inches of particle board that make the floor of the worship center, the access point in on the ceiling here.

Thus far it has worked great. Everybody has the service they need. While hardwired is always preferred, sometimes we do need a device in a location where wifi is easiest and hardwire is just a tripping hazard. This access point does a great job of empowering us to get the rate we need for critical devices.

One other interesting note. Mac and PCs are very different in some interesting ways. Mac's always seem to have very good wifi support, PCs do not. Macs always have 2&5 ghz wifi, PCs do not. When I look at the specs for PCs/Laptops I often find their wifi card supports both, however further research discovers that many manufacturers do NOT include a 5ghz antenna in their design where Apple always does. 5 ghz support is a big deal and can make or break streaming. It was a bit shocking to find the games PCs make by listing cards with 2 and 5 ghz support but not stating there is no 5 ghz antenna ......

I have found the cheap Amazon 2/5 ghz usb dongles for $20 will fix the wifi issue of PC laptops. These dongles have large ugly antennas with good gain as well having 5ghz support.

So to review:

1) Hardwire if you can
2) Get a high end access point that gives you good control over network metering
- Clamp down HARD on guests to make sure Wifi does what you need
3) If you have to use wifi make sure you have dedicated data rate that guests can not use up on you
4) Use MACs if you can, if you have to use a PC verify it has 5ghz support, get a dongle if it does not

BTW I can access the Unifi HD from the other part of our building 150+ feet away. This thing works great. The guest network does have a password that gets changed periodically so the residential neighbors don't get a free ride. Yes, the HD also works will out into the parking lot and property boundary, some neighbors could easily access it. For reference, our ISP service is 150 down and 20 up. This week I will be bringing 2 more Mini Pros on line for 3 concurrent Live Streams on Sundays (English, Spanish and Signing), so we are about to test the 20 up rate. :) I would NEVER try running the Mini Pro over WiFi in our church, but if you need to then hopefully the above will be useful to you. I have helped some other churchs and I have seen how unavoidable wifi can be, like having the modem in a different building and using wifi to span those buildings because running ethernet is too hard.

HTH!
Offline

CoolToysTV

  • Posts: 3
  • Joined: Sat Jun 06, 2020 9:56 pm
  • Real Name: Scott Neal

Re: ATEM Mini Pro - Stream problems

PostTue Aug 25, 2020 10:32 pm

Same issue. We used to just make it act like a webcam and used OBS. This method worked in the past.

We use Vimeo Pro which isn't supported by Black Magic. We hope this changes.

Our test environment has several different computers and software packages as we set up for live feedback via Fan2Stage app.

Using single camera and OBS was painful until the bigger MacBook Pro or Mac Pros were used on the system. We are trying to find the smallest and least expensive computer to run this.

OBS got so bloated we switched to Livestream Studio.
Here is what worked today -
ATEM Mini Pro
MacBook Air 2020 i5/8gb
Livestream Software to stream to YouTube, Facebook and Vimeo simultaneously selecting the ATEM as the WebCam. Audio did not work from the two mic ports on ATEM only from Cameras?

Could not get ATEM software to directly connect to any service as others have said.
Offline

mtbills

  • Posts: 5
  • Joined: Fri Sep 11, 2020 3:26 am
  • Real Name: Matthew Bills

Re: ATEM Mini Pro - Stream problems

PostFri Sep 11, 2020 3:49 am

msfelicio wrote:Hi I'm having similar issues with the Atem mini Pro.

We were streaming church services normally for weeks, one day with no particular explanation we couldn't get to stream. The ON AIR started, but approximately with 1 minute of stream cache starts to grow.

We observed that in M/V the timer next to ON AIR stopped and we couldn't get switch the streaming off by pressing the off button on the panel or in the software. Video cutting works fine. We can only try stream again by unplugging the device form the outlet.

We tried changing the quality and just got to stream in the "Hiperdeck Low" quality. Even trying Streaming low medium and High, only at hiperdeck low it worked. Yesterday was the opposite, nothing worked but streaming low. Our network connection is fine. We have 200down/60up fiber link. Speed test show perfect connection and ping.

We are using atem DHCP directly connected to the ONT ("modem")

it seems to be a software issue, please help us BMD


We are having this exact same issue. msfelicio, were you able to find a solution?
Offline

zonuna

  • Posts: 40
  • Joined: Sat Jun 23, 2018 10:29 am
  • Real Name: Zonunkhuma Chawngthu

Re: ATEM Mini Pro - Stream problems

PostThu Nov 12, 2020 5:17 pm

I had the same issue lately, but solved the problem, I had streamed to youtube for several nights, then one night the problem stated above happened to me, the next day i checked the Atem software connection by usb connection, to my surprised the IP address and subnet had been changed, which i cannot figure out how it happened. changing them back to correct value makes it work again. This might not be the solution for everyone, but works for me.
Offline

SchwobaDubbidu

  • Posts: 8
  • Joined: Tue Feb 19, 2019 1:16 pm
  • Location: Tübingen, Germany
  • Real Name: Niels Ott

Re: ATEM Mini Pro - Stream problems

PostTue Nov 17, 2020 6:15 pm

I'm having the same issue.

Atem Mini Pro does not connect to the Internet. Connected via Ethernet to my local network and thus to the router.

I tried pretty much everything. My Laptop is connected to the very same router and connects to YouTube and the rest of the Internet. The Atem Mini Pro is on DHCP, but does not connect to the Internet. The laptop connects to the Atem Mini Pro.

I bought the Atem Mini Pro in order to be independent from OBS. Is this device some kind of marketing fraud or are there people who actually use it for streaming directly?
Offline

SchwobaDubbidu

  • Posts: 8
  • Joined: Tue Feb 19, 2019 1:16 pm
  • Location: Tübingen, Germany
  • Real Name: Niels Ott

Re: ATEM Mini Pro - Stream problems

PostTue Nov 17, 2020 10:09 pm

So, some hours of testing and adrenaline later…

When I open up a dummy streaming server in the same IP subnet using netcat, the Atem Mini Pro does connect to it.

When I do the same on a different subnet, the Atem Mini Pro does not connect.

So, as it seems, as soon as the connection needs to be routed, it breaks. I'm on software version 8.5.2.

My laptop sits in the ethernet outlet next to the Atem Mini Pro on my router, it can connect anywhere I like, also stream to YouTube or Facebook using OBS. This rules out firewall filters and similar issues. I also tried to make the Atem Mini Pro connect to something via the router on port 80 which should generally not be affected by restrictions… same story. No way through.

I tried fixed IP and gateway settings as well as DHCP on the Atem Mini Pro. I think the firmware is broken or the device is broken. Has cost me 1 day of work so far to figure this out.
Offline

SchwobaDubbidu

  • Posts: 8
  • Joined: Tue Feb 19, 2019 1:16 pm
  • Location: Tübingen, Germany
  • Real Name: Niels Ott

Re: ATEM Mini Pro - Stream problems

PostTue Nov 17, 2020 10:48 pm

As a last resort, I tried downgrading the firmware, but I only got the notice that the firmware update failed and the Atem Mini Pro needed rebooting.
Offline

Xuan-Minh

  • Posts: 1
  • Joined: Wed Nov 18, 2020 1:39 pm
  • Real Name: Xuân-Minh Fritschy

Re: ATEM Mini Pro - Stream problems

PostWed Nov 18, 2020 2:33 pm

I had the same problem, it was driving me crazy all day. I was just able to get streaming with the Ethernet cable to work again. I just completed uninstalled the Atem Control Software from my Mac, restarted, and re-installed it.
Offline

stuartbaileymedia

  • Posts: 1
  • Joined: Wed Nov 18, 2020 3:17 pm
  • Real Name: Stuart Bailey

Re: ATEM Mini Pro - Stream problems

PostWed Nov 18, 2020 4:50 pm

The same thing has been driving me crazy but I think I've narrowed it down to a laptop issue if anyone can help?

*ATEM mini Pro connects to Windows laptop through ethernet using DHCP, allowing me to use control software.

*Laptop WiFi setting is set to shared but when I try to stream to FB/YT I get the flashing On Air and it won't stream. This is using both my home wireless network and 4G hot-spot via my mobile phone.

*if I plug the ethernet from the mini direct to the router the laptop still picks up the atem software on the network and it streams without a problem.

*Therefore the ATEM works fine but I presume there is a communication problem between the ethernet and wireless connections on my laptop.

Any ideas? I'm not particularly network savvy but can usually stumble through but not sure what to check

Thanks



Sent from my LYA-L09 using Tapatalk
Offline

SchwobaDubbidu

  • Posts: 8
  • Joined: Tue Feb 19, 2019 1:16 pm
  • Location: Tübingen, Germany
  • Real Name: Niels Ott

Re: ATEM Mini Pro - Stream problems

PostThu Nov 19, 2020 4:20 pm

I did some more research and contacted other users from my bubble on Facebook.

I cannot say 100% for sure but I think software/firmware 8.5.x simply has broken direct streaming in the Atem Mini Pro. One person reported it to work with 8.4.x

BM did not answer my support request. To rule out defective hardware, I will return the unit to my retailer and order another one somewhere else. Unhappy retailers, I must say, since they list features of the Atem Mini Pro that it probably does not provide, invalidating sales contracts.

Quite a lot of hassle and if it wasn't for the Covid situation and its significant drop in jobs and turnover, I would for sure have gone for the Roland VHD1 + some standalone HDMI h264 streaming encoder.
Offline

SchwobaDubbidu

  • Posts: 8
  • Joined: Tue Feb 19, 2019 1:16 pm
  • Location: Tübingen, Germany
  • Real Name: Niels Ott

Re: ATEM Mini Pro - Stream problems

PostSat Nov 21, 2020 12:59 pm

I reveiced my other ATEM Mini Pro today. It has software 8.5.1 in the device. Does stream to YouTube without any issue.

So either the previous device had a hardware issue or software 8.5.2 is broken. It is now up to BM to investigate this and if needed fix it in a version 8.5.3
Offline

Canyons

  • Posts: 65
  • Joined: Fri May 22, 2020 10:14 pm
  • Real Name: Charles Christopher

Re: ATEM Mini Pro - Stream problems

PostSun Nov 22, 2020 9:30 pm

Had an issue today using 8.5.2, using Vimeo which allows 3 streams max for our account.

When I have had issues it has been when we have all 3 AMP's running, versus earlier in the day when we just have 1 Live Stream running.

When I fired up the 3rd AMP before service, to make sure everything was working, the ON AIR button just kept flashing and did not go solid. I stopped and restarted and it went solid. Since I don't recall ever seeing this failure before I went through the ethernet wiring, switches, and router, everything seemed fine. I also rebooted the router. So at this point the network was off my radar and the ATM was now on it. :)

I reattempted the key presses, everything worked as normal. Power cycled AMP a couple of times, saw the same problem. Ok, so the ATM seems unhappy this morning. But then cycling through on/off air worked as normal. So at this point I think everything is fine, but that AMP is not behaving as usual. Getting a bit cold in that Sanctuary for what its worth and we just turned the heat on.

Service is about to start and we go live on all three streams, now I find I have a problem on the ATM mentioned above. Vimeo reports this steam is currently being fed by another devices, and the video is alternating from blank to the stream we are sending.

I have seen this issue before and I've attributed it to Vimeo, thinking we are using all 3 streams and are now attempting a 4th. I still think Vimeo does have an issue in this record and have discussed it with them, I'm not sure many of their users max out their streams like we do all at the same time.

I'm starting to think that the ATM, when "flashing forever" may have established a connection with Vimeo and failed to realize this which counted against our 3 streams. When we then went live it was inside whatever timeout window Vimeo has (Socket level or otherwise) and the next "On Air" pressed got us to 4 streams and thus Vimeo reporting we have another device sending a stream to that key.

After about 15 minutes (?) of watching this trying to wrap my head around what I was seeing, I quickly switched that ATM to "Off Air" and then back to "On Air" and everything worked as it should.

Reading other posts I'm wondering if this is what others are seeing, the platform thinks the ATM is sending two streams. I doubt that is happening, but perhaps the AMP is creating a second network socket with the same key before the previous socket has been closed or timed out. Just a thought .... If true there is nothing that can be done locally until the platform clears it on their end, and what I've seem of Vimeo they "latch up" pretty hard on their end.

We are going to back down to 8.5 and see what happens.

HTH

PS Vimeo has another time window that I have to work inside of and causes issues sometimes. On YouTube we could just hit "On Air" on the AMP and let is sit for hours before going live in their console, they did not care. Not so with Vimeo. If we don't go live in Vimeo inside some time window, of which I don't know the length of, they just ignore the stream with no indication of this state until we go live and get a blank screen in the Live Stream.
Offline

Jim Simon

  • Posts: 11137
  • Joined: Fri Dec 23, 2016 1:47 am
  • Warnings: 1

Re: ATEM Mini Pro - Stream problems

PostSun Nov 22, 2020 9:50 pm

rogersuski wrote:Is the ATEM able to "see" the internet?

How does one test that?
Offline

Canyons

  • Posts: 65
  • Joined: Fri May 22, 2020 10:14 pm
  • Real Name: Charles Christopher

Re: ATEM Mini Pro - Stream problems

PostSun Nov 22, 2020 11:26 pm

Jim Simon wrote:
rogersuski wrote:Is the ATEM able to "see" the internet?

How does one test that?


Great question!

AMP is picking up an NTP server somewhere as the videos are observed always index by the right time of day and timezone. But that is an after the fact observation.

Add that to a debug page:

1) Mac Address
2) HDMI port status of each port
3) Internet connection status, clock with "last seen X seconds ago" would be useful confirmation, so long as NTP server is not local and preferably outside ISP range as well. Perhaps "ping" of currently indexed Live Stream platform

Return to Live Production

Who is online

Users browsing this forum: WahWay, Xavier Quilambaqui and 18 guests