Video Assist Web output delayed

Questions about ATEM Switchers, Camera Converter and everything live!
  • Author
  • Message
Offline

jallen0

  • Posts: 446
  • Joined: Sun Jun 21, 2020 7:04 pm
  • Real Name: Justin Allen

Video Assist Web output delayed

PostSun Feb 21, 2021 6:56 pm

Hoping I can get some quick help here. I am running a Video Assist 12G HDR 7" USB feed to a Mac computer. I have successfully run this configuration before however for some reason I am getting a delay of the video feed by 1-3 frames today. This delay shows up on both the FaceTime camera as well as the zoom feed. If I use the internal camera I do not see any delay.

I have tried 2 different video assist 7" monitors, 2 BMPCC 6K cameras and even my Sony A7sIII camera, all being fed from the Video Assist Monitors. I have tried multiple cables, including Apple's $130.00 Thunderbolt cable. I have also tried two different Mac OS X Big Sur computers.

I even tried the UltraStudio 3G Recorder and all the computers saw from that was the audio, not the video.

At this point I am out of things to try and was wondering if anyone had any clues as to what might be happening. Like I said, this has worked before.
2019 MacPro Ver 11.1, 160GB Mem, 4TB Drive, 4TB Internal Sonnet Raid, Dual Radeon Pro W5700X 16GB
LG UF 5k, 27" Thunderbolt Display, 55" LG C8 OLED
Resolve Editor Keyboard, Mini Panel, Ultrastudio 4K Mini
Resolve Studio Ver. 17.1
Offline

jallen0

  • Posts: 446
  • Joined: Sun Jun 21, 2020 7:04 pm
  • Real Name: Justin Allen

Re: Video Assist Web output delayed

PostSun Feb 21, 2021 11:05 pm

I also want to add that I tried hooking up a ATEM Mini Pro ISO and I ran the HDMI cable to the ATEM and then attached a USB cable to it and the computer. The name of the ATEM device showed up but I could not get any video into the computer at all. Everything remained black.

It have no issue using the built-in webcams from several monitors or an external Logitech...they all work perfectly. It just using any Blackmagic device introduces the video latency.

So very frustrated right now after spending the entire day working on this. And I have a streaming event tomorrow afternoon.
2019 MacPro Ver 11.1, 160GB Mem, 4TB Drive, 4TB Internal Sonnet Raid, Dual Radeon Pro W5700X 16GB
LG UF 5k, 27" Thunderbolt Display, 55" LG C8 OLED
Resolve Editor Keyboard, Mini Panel, Ultrastudio 4K Mini
Resolve Studio Ver. 17.1
Offline

jallen0

  • Posts: 446
  • Joined: Sun Jun 21, 2020 7:04 pm
  • Real Name: Justin Allen

Re: Video Assist Web output delayed

PostMon Feb 22, 2021 3:48 pm

Update: I tried a Catalina system and still experienced the same issue. I downgraded the Video Assist monitors to 3.3 and still had the same issue.

My frustration lies in that this same set-up worked two weeks ago with zero issues and now, no matter what I do I cannot get the latency to go away when using the Video Assist Monitors.

I submitted a support ticket to Blackmagic 24 hours ago but have heard nothing yet. I do realize that their responses usually take longer than that but in mission critical issues it's a bit frustrating.
2019 MacPro Ver 11.1, 160GB Mem, 4TB Drive, 4TB Internal Sonnet Raid, Dual Radeon Pro W5700X 16GB
LG UF 5k, 27" Thunderbolt Display, 55" LG C8 OLED
Resolve Editor Keyboard, Mini Panel, Ultrastudio 4K Mini
Resolve Studio Ver. 17.1
Offline

jallen0

  • Posts: 446
  • Joined: Sun Jun 21, 2020 7:04 pm
  • Real Name: Justin Allen

Re: Video Assist Web output delayed

PostTue Feb 23, 2021 2:06 am

Update: I used a Sony A7sIII and downloaded the webcam software for it. I have it running out of the camera into the computer and there is zero latency.

I can only conclude that the latency issue originates with the USB out of the Video Assist monitors as I can get everything to work once I take them out of the loop.

Waiting on Blackmagic support to reply and see what their thoughts are.
2019 MacPro Ver 11.1, 160GB Mem, 4TB Drive, 4TB Internal Sonnet Raid, Dual Radeon Pro W5700X 16GB
LG UF 5k, 27" Thunderbolt Display, 55" LG C8 OLED
Resolve Editor Keyboard, Mini Panel, Ultrastudio 4K Mini
Resolve Studio Ver. 17.1
Offline

jallen0

  • Posts: 446
  • Joined: Sun Jun 21, 2020 7:04 pm
  • Real Name: Justin Allen

Re: Video Assist Web output delayed

PostWed Feb 24, 2021 12:11 pm

Update: 48 hours after submitting a support ticket the answer I received from Blackmagic concerning a delayed response from the Video Assist monitors is this:

"Anytime HDMI is used between devices for streaming, you may experience a slight delay-
there are no adjustments that can be made to compensate for this, unless there are delay functions in the software being used."


So basically using your Video Assist monitor as a webcam is impossible. Not sure what this feature is useful for then for software like FaceTime, or Zoom. Maybe with OBS you can introduce audio delays to make it work.

I did reply that there is zero delay from the cameras to the Video Assist monitor using HDMI and that the delay appears between the USB out and the computer input. I am not sure this is an HDMI delay in this case but we'll see what their response is.
2019 MacPro Ver 11.1, 160GB Mem, 4TB Drive, 4TB Internal Sonnet Raid, Dual Radeon Pro W5700X 16GB
LG UF 5k, 27" Thunderbolt Display, 55" LG C8 OLED
Resolve Editor Keyboard, Mini Panel, Ultrastudio 4K Mini
Resolve Studio Ver. 17.1
Offline
User avatar

ishootyou.com

  • Posts: 189
  • Joined: Mon Jul 08, 2019 6:09 pm
  • Real Name: Nick Schreger

Re: Video Assist Web output delayed

PostWed Feb 24, 2021 4:33 pm

I suppose your problem is out-of-sync audio. In that case you should feed the audio to the Video Assist instead of using the microphone of your computer (or the mic input). It is true that HDMI induces latency, but it's only half of the truth. Every device in the signal chain induces some kind of latency. Panasonic cameras are horrible in this regard, Sony a lot better. Given the fact that the Video Assist had never been planned to be used as a webcam, I wouldn't blame it too much. In case that you have to use audio being fed to the computer, there are cheap (about 80USD) devices that ad latency to the audio feed in order to match it with video.
------------------------
ishootyou.com
Teaching photography and videography in Switzerland
Offline

jallen0

  • Posts: 446
  • Joined: Sun Jun 21, 2020 7:04 pm
  • Real Name: Justin Allen

Re: Video Assist Web output delayed

PostWed Feb 24, 2021 5:59 pm

Great reply, thanks.

The latency issue is video driven. Once it's plugged into the computer the image on the screen is delayed. This happens in Zoom and Facebook. So when talking the image is behind the audio. The audio in this case just talking either without a device, or with a USB mic. So the audio is not part of the chain.

Again when using the same computer with the same software and a direct USB feed from the Sony camera, there is no delay. I agree that every device causes latency, in this case, since the HDMI feed shown on the Video Assist shows no latency, and the latency shows up once it leaves the Video Assist through the USB cable, I think is a reasonable assumption that the USB out is causing the latency. As I have shown that the USB in from another device does not produce latency.
2019 MacPro Ver 11.1, 160GB Mem, 4TB Drive, 4TB Internal Sonnet Raid, Dual Radeon Pro W5700X 16GB
LG UF 5k, 27" Thunderbolt Display, 55" LG C8 OLED
Resolve Editor Keyboard, Mini Panel, Ultrastudio 4K Mini
Resolve Studio Ver. 17.1

Return to Live Production

Who is online

Users browsing this forum: Nicholas Gill and 32 guests