Key/Fill pixel offset with UltraStudio HD Mini

Questions about ATEM Switchers, Camera Converter and everything live!
  • Author
  • Message
Offline

floriandobler

  • Posts: 5
  • Joined: Mon Mar 22, 2021 1:59 pm
  • Real Name: Florian Dobler

Key/Fill pixel offset with UltraStudio HD Mini

PostMon Mar 22, 2021 4:25 pm

Hi,

I have a pixel offset when using the two SDI outputs as Key & Fill, and I hope you can help me fix it.

EQUIPMENT:
Resolume Arena > UltraStudio HD MINI > 2x MicroConverter BiDirectional 3G > ATEM Mini Extreme ISO
Computer: MacBook Pro 2019 16" running macOS 10.15.7 Catalina

APPROACH:
I am playing video with Alpha Channel (QT ProRes 4:4:4:4)
In Advanced Output I select the UltraStudio as an output with the correct resolution (1080p50)
Color Range, Color Space and Alpha Type do not alter my results
I convert both SDI signals to HDMI and go into two inputs of the ATEM
In ATEM Software Control I setup the Downstream Key 1 with Pre Multiplied Key and no mask
As a background I set a orange color

EXPECTED BEHAVIOUR:
A perfect key :)

OBSERVED BEHAVIOUR:
Key and Fill seem to be offset by a couple of pixels horizontally. Threre doesn't seem to be a time offset. When I change some settings in Resolume (Keyer External vs. Internal) the offset shifts, but it's never perfect.

Some images here, the last one is a reference (how it's supposed to look like):
https://photos.app.goo.gl/5R5p2NeCgsYqsMve8

Thanks!
Offline

retailgeek

  • Posts: 6
  • Joined: Sat Mar 27, 2021 1:44 am
  • Real Name: Jason Goldberg

Re: Key/Fill pixel offset with UltraStudio HD Mini

PostSat Mar 27, 2021 4:57 am

Let me know if you learn anything on this. I'm having a similar issue. When I play a video from my hyperdeck mini (Prores 4444 w/ Alpha), and use the Key and Fill outputs, the key is slightly offset as well, giving me an ugly black halo.
Offline

floriandobler

  • Posts: 5
  • Joined: Mon Mar 22, 2021 1:59 pm
  • Real Name: Florian Dobler

Re: Key/Fill pixel offset with UltraStudio HD Mini

PostMon Mar 29, 2021 4:06 pm

I'll make sure to reply here. I've filed a support ticket with Blackmagic, but so far there has been radio silence.
Offline

retailgeek

  • Posts: 6
  • Joined: Sat Mar 27, 2021 1:44 am
  • Real Name: Jason Goldberg

Re: Key/Fill pixel offset with UltraStudio HD Mini

PostTue Mar 30, 2021 12:34 am

Hey Florian,

In my case, I noticed that the offset between key and kill was actually getting worse (on the same files in the same configuration), which led me to try rebooting my Hyperdeck. In my case, that seemed to bring the Fill & Key back in sync, and the key is (for now) perfect. I'll be watching over time to see if it drifts again.

I'm Using a HyperDeck Mini -> SDI2HDMI -> Atem Mini Extreme Pro so not the same chain as you, but I wonder if you're having a similar issue.
Offline
User avatar

Roman Pytkin Pekarek

  • Posts: 1818
  • Joined: Tue Oct 30, 2012 1:11 pm
  • Location: SVK

Re: Key/Fill pixel offset with UltraStudio HD Mini

PostTue Mar 30, 2021 11:26 pm

Im using Ultrastudio HD MIni with CASPAR CG and getting perfect sync between KEY and FILL
http://www.media-planet.sk
http://www.stonepp.tv
http://tally.pytkin.sk
Offline

poehlerstreet

  • Posts: 2
  • Joined: Sat Apr 03, 2021 12:27 pm
  • Real Name: Frank Lehmann

Re: Key/Fill pixel offset with UltraStudio HD Mini

PostSat Apr 03, 2021 12:30 pm

@floriandobler I have the same setup and the same issue from time to time. The simple yet awkward solution is to plug the HDMI cable out and in again. Then the issue is gone most of the time.
I also get this with my camera inputs sometimes.
Offline

floriandobler

  • Posts: 5
  • Joined: Mon Mar 22, 2021 1:59 pm
  • Real Name: Florian Dobler

Re: Key/Fill pixel offset with UltraStudio HD Mini

PostTue Apr 06, 2021 1:02 pm

@poehlerstreet You are absolutely right! I have to replug both HDMI cables and the key becomes perfect. Unfortunately I have to to this everytime I turn off the system, so it's not-so-great as a permanent solution, but for now it works. thanks!

BTW, unfortunately I have yet to receive any reply from Blackmagic on the issue despite reaching out to them multiple times in the last two weeks.
Offline

poehlerstreet

  • Posts: 2
  • Joined: Sat Apr 03, 2021 12:27 pm
  • Real Name: Frank Lehmann

Re: Key/Fill pixel offset with UltraStudio HD Mini

PostTue Apr 06, 2021 2:04 pm

@floriandobler That might be a timing issue. There may be a perfect order to turn on all the devices in the chain. But this shouldn't be the case. Sounds like a problem that can be fixed via software.
Thanks for reaching out to BM. You can send them a link to this thread so they know that there are at least two people with the problem :).
Offline

floriandobler

  • Posts: 5
  • Joined: Mon Mar 22, 2021 1:59 pm
  • Real Name: Florian Dobler

Re: Key/Fill pixel offset with UltraStudio HD Mini

PostWed Apr 07, 2021 4:31 pm

Might be, and I'm starting to suspect the converters instead of the UltraStudio. Further testing gave these results:

replugging both HDMI cables REMOVES the offset
power cycling the converters CREATES the offset
power cycling the ATEM Switcher REMOVES the offset
power cycling the UltraStudio neither removes nor introduces the offset
changing the output format in Resolume CREATES the offset
using different software does NOT remove the offset
Offline
User avatar

ettnoll

  • Posts: 11
  • Joined: Mon Jul 13, 2020 10:13 am
  • Location: Stockholm, Sweden
  • Real Name: Tobias Olsson

Re: Key/Fill pixel offset with UltraStudio HD Mini

PostWed Apr 07, 2021 4:55 pm

Check the settings in Desktop Video. At least for the Decklink cards there's a setting for pixel offset.
Offline

floriandobler

  • Posts: 5
  • Joined: Mon Mar 22, 2021 1:59 pm
  • Real Name: Florian Dobler

Re: Key/Fill pixel offset with UltraStudio HD Mini

PostWed Apr 07, 2021 5:32 pm

Thanks, but if you read the posts above, you see that the offset is fluctuating and that there is a way to achieve zero offset, so it's definitely not something you would want to correct by setting another offset.
Offline
User avatar

ettnoll

  • Posts: 11
  • Joined: Mon Jul 13, 2020 10:13 am
  • Location: Stockholm, Sweden
  • Real Name: Tobias Olsson

Re: Key/Fill pixel offset with UltraStudio HD Mini

PostWed Apr 07, 2021 8:17 pm

Right. Didn't take that into consideration. Sounds like a really strange bug. But just to be sure, did you test it, or at least check that the value there doesn't change?

Return to Live Production

Who is online

Users browsing this forum: redline and 32 guests