Page 1 of 1

M1 MBP Ventura 13.2.1 Ultrastudio Recorder 3G

PostPosted: Sun Mar 26, 2023 3:09 pm
by RobertHDPF
Ultrastudio Recorder 3G won't connect to any thunderbolt ports on my M1 MBP. The error I'm getting says - "Cannot Use Thunderbolt Accessory - Connect accessory to a Thunderbolt port on this Mac." Desktop Video Display is installed and doesn't see the device. I've tried several thunderbolt cables and 2 different Ultrastudio devices. Tried changing security settings and gave the device permission. I need these devices to work ASAP. Thanks

Re: M1 MBP Ventura 13.2.1 Ultrastudio Recorder 3G

PostPosted: Tue Mar 28, 2023 4:18 am
by Jonathan Evans
Make sure you are the administrator of the OS.
If the device is not detected in BM Desktop Video Setup:
-Confirm the correct cable &/or adapters are being used.
-Visually confirm the cable and adapters have the Lightning symbol.
-Confirm the white LED is lit up near the Thunderbolt Port on the Recorder.
-Try with another port if possible. Avoid using a hub for the purpose of testing.
-On Mac, make sure you haven’t ignored the Mac OS security saying you need to “Allow” extensions during the install System prefs - Security & Privacy-General - Allow apps downloaded from - App Store and identified devs-System software from developer Blackmagic. May need restart after changing Security settings.
-On some Macs Thunderbolt 4 cables won’t work so try Thunderbolt 3.
-On some Macs need to use short cables.
-On some computers you need to “allow” BlackMagic Desktop software through the Firewall.