Page 3 of 3

Re: Arduino Shield Thread

PostPosted: Thu Apr 11, 2019 12:09 pm
by davidH
Anyone nows how to make it work with the Arduino Leonardo?
I have it working with the uno buy I can't make it work with the Leonardo. I connected GND, sda and scl from Leonardo pins that are different from uno.
Thank you.

Re: Arduino Shield Thread

PostPosted: Thu Apr 11, 2019 5:25 pm
by Xtreemtec
Should not be a problem.. The i2c connector on the leonardo is also near the reset button. As well as on the SDI board.

bmdSdiShieldPinout.png
bmdSdiShieldPinout.png (21.69 KiB) Viewed 642 times

Re: Arduino Shield Thread

PostPosted: Sun Feb 02, 2020 4:40 pm
by Keksstar
Does anyone have an example code for the getcameratally command?

Re: Arduino Shield Thread

PostPosted: Wed Feb 05, 2020 8:00 pm
by Keksstar
Alrighty... got it workin with the help of Daniel Wittenaar :)

Re: Arduino Shield Thread

PostPosted: Wed Apr 22, 2020 10:09 am
by -Nick-
Hello everyone,

I am currently developing a camera remote control and unfortunately hang in one place.
I don't get the following commands to work:

SDI-Overlay.png
SDI-Overlay.png (10.83 KiB) Viewed 255 times

SDI-FocusAssist.png
SDI-FocusAssist.png (21.24 KiB) Viewed 255 times


Did anyone ever get these commands up and running?
Could someone send me a code sample?
Besides, I don't understand how to interpret the int 16 bit-field.
The rest of my code is working fine.

I would be very pleased to receive an answer.
Greetings from Germany,
Nick

PS.: I use a shield with the current software version 1.1.
As a camera I use a Ursa Mini 4k. But I also tried it with a Ursa fullsize and a Ursa Mini Pro G1.

Re: Arduino Shield Thread

PostPosted: Wed Apr 22, 2020 10:30 pm
by mizelly41
Is the shield able to read the incoming tally?
I am interested in hooking up an LED to the Arduino and making my own tally light at a non Blackmagic camera.

Re: Arduino Shield Thread

PostPosted: Mon May 11, 2020 10:38 am
by Valentin_Pscheidl
Im currently getting started with the shield. Most of the commands I like to use I got working, but my main problem with the shield ist getting my PGM through the device while controlOverwrite ist active. I only reseave a frame at my camera in the second I refresh a command (LED 4 blinks at the shield). This isn't just a problem of my custom sketches, it also takes place with the example PotZoom Sketch.
Did anyone had simular experience and found a solution?

Gesendet von meinem SM-N950F mit Tapatalk

Re: Arduino Shield Thread

PostPosted: Wed Jul 22, 2020 10:15 pm
by fenderam07
Hi, I'm having in issue with initiating an Auto White Balance command via arduino. I'm able to make the Instantaneous Auto Focus work which uses the same command format.

The Auto White Balance type is void, so calling the command should work, but doesn't. Here's the function I made:

// This sends a white balance adjustment command, with a simple camera control packet.
void autoWhiteBalance() {

sdiCameraControl.writeCommandVoid(
1, // Destination: Camera 1
1, // Category: Video
3 // Paramter: Auto White Balance
);
}



Can anyone verify if they've gotten this function to work?
Thanks!