Resolve crashing on delivery

  • Author
  • Message
Offline

2fanatyk2

  • Posts: 19
  • Joined: Tue May 15, 2018 6:39 pm
  • Real Name: Adam Wojciechowski

Resolve crashing on delivery

PostTue Sep 17, 2019 11:49 am

Everytime I'm trying to export a timeline, Resolve crashes after 2-3 minutes (tried multiple projects).

Exporting FHD timeline at approx 190-220 FPS, suddenly stopping for 3-4 seconds and Resolve window is disappearing.

There is no single "spot", where it crashes - seems to be random and time-bound, rather than resource/file-bound. Tired turning off auto-save, but it didn't help.

In task manager process is still there, but with 0% CPU utilization and using only 3 GB of memory (32 GB available)

Version: 16B3
Offline

2fanatyk2

  • Posts: 19
  • Joined: Tue May 15, 2018 6:39 pm
  • Real Name: Adam Wojciechowski

Re: Resolve crashing on delivery

PostTue Sep 17, 2019 11:55 am

Tried limiting Render Speed to 100 FPS - seems more stable now. Still, the issue if there - but if anybody has similar problem, this seems to be a temporary fix.
Offline

Das Kid

  • Posts: 8
  • Joined: Wed Sep 18, 2019 1:01 am
  • Location: New Zealand
  • Real Name: Kris Leys

Re: Resolve crashing on delivery

PostWed Sep 18, 2019 10:28 am

I've done some further testing.

In 16.1b3, Macos 10.14.6, MacPro6,1 (D700s).

A one hour timeline of Canon C300 MXF 1080p25 media fails to export.

I've tried ProRes, h.264, and Vimeo presets (I know it's just another h.264), and several custom variations.

I've created optimised (ProRes) media and tried to export with that.

I've tried limiting rendering speed.

I've tried changing media drives. And export locations.

I'm experiencing either an error dialogue with differing errors from "fails to read clip" to "fail to write file" because of "permissions". Or a hard crash out. The error occurs and random intervals. Usually within first 15 minutes of export. Although I did have one run make it to 75% before failure.

Is anyone else seeing similar behavior?
MacPro 6,1 (D700, 32Gb, 10.14.6)
Acer Aspire V Nitro (GTX 960M, 16Gb, Win 10 1903)
Offline

Das Kid

  • Posts: 8
  • Joined: Wed Sep 18, 2019 1:01 am
  • Location: New Zealand
  • Real Name: Kris Leys

Re: Resolve crashing on delivery

PostThu Sep 19, 2019 12:04 am

I've replicated the behaviour on a windows machine.

Timeline is exclusively Cannon XF-AVC Intra 25fps 1080 x 1920. One hour of material from one source. About 20 clips.

I'm using 16.1b3 Studio. Latest update of windows 10. Latest nvidia drivers.

Will crash out at random intervals during render to h.264 using either native encoder or nvidia one. Resolve process then continues to run in background until I manually kill it.

Will now test with different media....
MacPro 6,1 (D700, 32Gb, 10.14.6)
Acer Aspire V Nitro (GTX 960M, 16Gb, Win 10 1903)
Offline

Das Kid

  • Posts: 8
  • Joined: Wed Sep 18, 2019 1:01 am
  • Location: New Zealand
  • Real Name: Kris Leys

Re: Resolve crashing on delivery

PostThu Sep 19, 2019 12:35 am

Further testing...

I can replicate the same issue using mp4(h.264) files from a DJI Mavic as the source files.

Or DNG RAW files from a DJI XR5.

In all cases a longer timeline will fail to render out to either h.264 or ProRes.

This is on a MacPro 2013 (D700s), MacOS 10.14.6, with 16.1b3 Studio.

I've conducted the test over multiple project databases and projects, with or with out burnt in data, and a variety of export settings, including limiting render rate. So far no luck.

I'd welcome any thoughts or suggestions.
MacPro 6,1 (D700, 32Gb, 10.14.6)
Acer Aspire V Nitro (GTX 960M, 16Gb, Win 10 1903)
Offline

Das Kid

  • Posts: 8
  • Joined: Wed Sep 18, 2019 1:01 am
  • Location: New Zealand
  • Real Name: Kris Leys

Re: Resolve crashing on delivery

PostThu Sep 19, 2019 2:42 am

I've now rolled my Windows machine back to 16.1b2 and the issue has been "resolved".

Appears to be a bug specific to beta 3 from where I'm standing.
MacPro 6,1 (D700, 32Gb, 10.14.6)
Acer Aspire V Nitro (GTX 960M, 16Gb, Win 10 1903)
Offline

Rohit Singhal

Blackmagic Design

  • Posts: 334
  • Joined: Wed Aug 22, 2012 11:07 am

Re: Resolve crashing on delivery

PostThu Sep 19, 2019 9:27 am

Can you post your logs?

More info here - viewtopic.php?f=21&t=90190
Rohit Singhal
DaVinci Resolve Software Development
Blackmagic Design
Offline

Das Kid

  • Posts: 8
  • Joined: Wed Sep 18, 2019 1:01 am
  • Location: New Zealand
  • Real Name: Kris Leys

Re: Resolve crashing on delivery

PostMon Sep 23, 2019 2:29 am

I've done a clean reinstall of Resolve 16.1b3 on both the windows and Mac machines.

Both are now behaving correctly.

In both cases I had upgraded from b2 to b3 by just running the installer and installing over the top of b2.

Something must have been messed up in that process.

Hope it helps anyone who runs into a similar issue.
MacPro 6,1 (D700, 32Gb, 10.14.6)
Acer Aspire V Nitro (GTX 960M, 16Gb, Win 10 1903)
Offline
User avatar

Thomas Milde

  • Posts: 226
  • Joined: Tue Aug 28, 2012 11:27 am
  • Location: Augsburg, Germany

Re: Resolve crashing on delivery

PostMon Sep 23, 2019 5:43 am

Thanks, good to know.

I had the same issue, and going back to 16.1b2 did the trick.
So now I can go back (forward?) to 16.1b3 again.
Tech:
Win 10 pro, Ryzen 5 1600x, 64 GB, SSDs for media
GTX 980 ti (442.50), Intensity Pro, DVR Studio 16.2, Desktop Video 11.4.1
Offline

Das Kid

  • Posts: 8
  • Joined: Wed Sep 18, 2019 1:01 am
  • Location: New Zealand
  • Real Name: Kris Leys

Re: Resolve crashing on delivery

PostWed Sep 25, 2019 8:58 am

Stay on 16.1b2.

I did run a days worth of tests without issue in 16.1b3 after a reinstall. But today the errors have returned.

I'm reverting to 16.1b2 for now.

Latest diagnostic log from Mac 16.1b3, failing to export to ProRes.
Attachments
DaVinci-Resolve-logs-20190925-204804.zip
(532.21 KiB) Downloaded 35 times
MacPro 6,1 (D700, 32Gb, 10.14.6)
Acer Aspire V Nitro (GTX 960M, 16Gb, Win 10 1903)
Offline

irongiant369

  • Posts: 1
  • Joined: Wed Dec 04, 2019 1:38 pm
  • Real Name: Carlos N. Nieves

Re: Resolve crashing on delivery

PostWed Dec 04, 2019 1:46 pm

I was having same issue and i follow, the advice from this forum to lower the speed of render, first to 100 still crashed then 70 and same thing , only when i lowered the speed to 50 only then the render was successfully, i have 12 core MacPro 64GiG Ram and running Catalina And still was having the problem until i Lowered the speed of the render. Good Luck Happy Editing :D
Offline

craigtull

  • Posts: 1
  • Joined: Mon Dec 09, 2019 3:51 am
  • Real Name: Craig Tull

Re: Resolve crashing on delivery

PostMon Dec 09, 2019 3:54 am

Iron giant how do you lower the render speed please? Can't find the option anywhere. Thanks.
Offline

Michael_Andreas

  • Posts: 1533
  • Joined: Sat Jan 05, 2019 9:40 pm
  • Real Name: Michael Andreas

Re: Resolve crashing on delivery

PostMon Dec 09, 2019 8:33 pm

Deliver page.
Render Settings panel
File tab
_________________________________________________
DR Studio 16.2.0.055, Win10Pro 1909/18363.535 - i7-6700K@4GHz, 32GB RAM
RTX 2070 8GB, "Studio" driver 442.19 2/3, prev: 441.66, 431.86
OS,Library: 1TB SSD - Project: 1TB SSD - Cache: 1TB NVMe
Offline

Richard Danek

  • Posts: 37
  • Joined: Mon Mar 06, 2017 4:44 am

Re: Resolve crashing on delivery

PostWed Dec 11, 2019 9:51 pm

I've been having this problem, crashing during Delivery without leaving any kind of log information, on my newer Windows 10 system. Out of desperation, I tried installing the Linux version of Resolve on my Linux Mint system and was able to get through Delivery. (Had to re-edit the project 1st time, next time I did an export on Windows and import to Linux...worked.) The problem is that I can't license the studio version on Linux Mint because it can't make a network connection.

So, I next took the Linux system and booted to Windows 10 on it. (This is my older system.) I installed Resolve Studio there, did the export import thing again and was agle to get through Delivery.

The newer system is a 3.6 Ghz Xeon with an Aorus 1080ti with 11GB memory. The older system is a 3 Ghz i5 with an nVidia 950 with 2GB memory. This is a clumsy way to do this but I can edit safely on the new system but can't deliver. I can deliver on the old system (but don't yet know what limitations there might be). In both cases, Windows 10 is up-to-date and the graphic card drivers a latest-greatest.

The only other difference is that the newer system is running Windows 10 Pro.

Truth be told, I'd rather try this all out on Linux but since the network connection for Resolve doesn't work I can't.

Weird.

I hope this is something that Black Magic can fix at some point as I can't figure out what the problem is otherwise.
RC Danek - System Configuration Information
-----
Intel e5-1620 CPU 3.6 Ghz
16 GB memory
Windows 10 Pro 64 bit, x64 processor
HP Z420 Workstation
465 GB SSD
NVIDIA Aeorus 1080ti 11GB GDDR5
1920x1080, 8-bit, RGB, Standard Dynamic Range
Offline

Richard Danek

  • Posts: 37
  • Joined: Mon Mar 06, 2017 4:44 am

Re: Resolve crashing on delivery

PostWed Dec 18, 2019 3:08 pm

I installed Studio 16.1.2 on my Windows system. I re-ran one of the projects that crashed on Deliver. The newest version finished the render with no apparent problems. So, YAY!!! ...at least until the next one I'll need to do (probably tonight).
RC Danek - System Configuration Information
-----
Intel e5-1620 CPU 3.6 Ghz
16 GB memory
Windows 10 Pro 64 bit, x64 processor
HP Z420 Workstation
465 GB SSD
NVIDIA Aeorus 1080ti 11GB GDDR5
1920x1080, 8-bit, RGB, Standard Dynamic Range
Offline

Richard Danek

  • Posts: 37
  • Joined: Mon Mar 06, 2017 4:44 am

Re: Resolve crashing on delivery

PostThu Dec 19, 2019 3:49 pm

I'm one for one on Delivery crashes. When I installed 16.1.2 on Windows and ran a previous project's Delivery, Resolve made it all the way through. I thought problem solved. Well, not so fast. A 2nd project, similar in file types, crashed this morning. So, I'm going to try to move the project over to my Linux system and see if I can get this project finished.

I'm very disappointed. I guess we wait for the next version. :-(
RC Danek - System Configuration Information
-----
Intel e5-1620 CPU 3.6 Ghz
16 GB memory
Windows 10 Pro 64 bit, x64 processor
HP Z420 Workstation
465 GB SSD
NVIDIA Aeorus 1080ti 11GB GDDR5
1920x1080, 8-bit, RGB, Standard Dynamic Range
Offline

Richard Danek

  • Posts: 37
  • Joined: Mon Mar 06, 2017 4:44 am

Re: Resolve crashing on delivery

PostThu Dec 19, 2019 9:48 pm

So, now that I was able to process a video through Delivery on a Linux Mint system (but with different hardware) and fail on my Windows 10 system (with its better GPU), I decided to do another test. I added a small SSD to my Windows system. I disconnected the WIndows 10 system disk completely and loaded up the newest Linux Mint on the new SSD. The install went smoothly and I used makeresolvedeb to create a deb file from the Resolve 16.1.2 download. I went with the non-studio version for this test because that's what I was using on my other Linux system (the one with the less powerful GPU). I had to find/install Mesa OpenCL separately when I got some error messages, but other than that, makeresolvedeb did the job.

So, I took the troublesome video project and imported it. I chanced the source directory to make all the video files visible. I started the render and it completed successfully. I noted an error in one of my titles so I corrected that and re-rendered. (I should call the Delivered and re-Delivered, I suppose.) In both cases, things flew quickly and successfully.

One of the things I worried about was that I might have a defective GPU (a used Aorus GTX 1080 Ti with 11 G memory). I'm convinced now that is not the case. More than likely Resolve, Windows 10 and/or nVidia's driver aren't happy together.

Now, as this was an experiment, I'm considering making the Linux disk a permanent part of my system via some dual-boot scheme. The only question is whether to go with Cent OS 8, Cent OS 7, or stick with Linux Mint (because I'm comfortable with Ubuntu).
RC Danek - System Configuration Information
-----
Intel e5-1620 CPU 3.6 Ghz
16 GB memory
Windows 10 Pro 64 bit, x64 processor
HP Z420 Workstation
465 GB SSD
NVIDIA Aeorus 1080ti 11GB GDDR5
1920x1080, 8-bit, RGB, Standard Dynamic Range
Offline

cmorrison

  • Posts: 4
  • Joined: Wed Dec 04, 2019 5:58 am
  • Real Name: Christian Morrison

Re: Resolve crashing on delivery

PostSun Dec 29, 2019 1:34 am

Same issue here exporting DNXHR - One the crash log is analyzed I get the following. Windows 10 1903 18328.535. Resolve 16.1.2.026.

Anyone know what Audioses is?

YMBOL_NAME: audioses!GetAudioServerBindingHandle+3e

MODULE_NAME: AudioSes

IMAGE_NAME: AudioSes.dll

STACK_COMMAND: ~114s ; .ecxr ; kb

FAILURE_BUCKET_ID: HEAP_CORRUPTION_c0000374_AudioSes.dll!GetAudioServerBindingHandle

OS_VERSION: 10.0.18362.1

BUILDLAB_STR: 19h1_release

OSPLATFORM_TYPE: x64

OSNAME: Windows 10

FAILURE_ID_HASH: {ccfd83b8-b6c4-3923-ab3d-ec5d200e1134}

-------------------------------
Full error info follows:
-------------------------------

KEY_VALUES_STRING: 1

Key : Analysis.CPU.Sec
Value: 5

Key : Analysis.DebugAnalysisProvider.CPP
Value: Create: 8007007e on METABOX

Key : Analysis.DebugData
Value: CreateObject

Key : Analysis.DebugModel
Value: CreateObject

Key : Analysis.Elapsed.Sec
Value: 291

Key : Analysis.Memory.CommitPeak.Mb
Value: 777

Key : Analysis.System
Value: CreateObject

Key : Timeline.Process.Start.DeltaSec
Value: 72927


ADDITIONAL_XML: 1

NTGLOBALFLAG: 0

PROCESS_BAM_CURRENT_THROTTLED: 0

PROCESS_BAM_PREVIOUS_THROTTLED: 0

APPLICATION_VERIFIER_FLAGS: 0

CONTEXT: (.ecxr)
rax=000002a2763b50a0 rbx=00000000c0000374 rcx=0000000000000000
rdx=00007ffc00000000 rsi=0000000000000001 rdi=00007ffcbcd227f0
rip=00007ffcbccb9269 rsp=000000ca7dafe610 rbp=0000029d78180000
r8=0000000000000000 r9=0000000100000000 r10=000000ca7dafec70
r11=0000000000000001 r12=0000000000000000 r13=0000029d8faaf9c0
r14=00007ffcb1049160 r15=0000000000000000
iopl=0 nv up ei pl nz na pe nc
cs=0033 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00000202
ntdll!RtlReportFatalFailure+0x9:
00007ffc`bccb9269 eb00 jmp ntdll!RtlReportFatalFailure+0xb (00007ffc`bccb926b)
Resetting default scope

EXCEPTION_RECORD: (.exr -1)
ExceptionAddress: 00007ffcbccb9269 (ntdll!RtlReportFatalFailure+0x0000000000000009)
ExceptionCode: c0000374
ExceptionFlags: 00000001
NumberParameters: 1
Parameter[0]: 00007ffcbcd227f0

PROCESS_NAME: Resolve.exe

ERROR_CODE: (NTSTATUS) 0xc0000374 - A heap has been corrupted.

EXCEPTION_CODE_STR: c0000374

EXCEPTION_PARAMETER1: 00007ffcbcd227f0

STACK_TEXT:
000000ca`7dafe610 00007ffc`bccb9233 : 000000ca`7dafeb50 00000000`00000000 0000029d`310be0d0 00007ffc`bcbfc4bf : ntdll!RtlReportFatalFailure+0x9
000000ca`7dafe660 00007ffc`bccc1622 : 00000000`00000032 00007ffc`bcd227f0 00000000`00000003 0000029d`78180000 : ntdll!RtlReportCriticalFailure+0x97
000000ca`7dafe750 00007ffc`bccc192a : 00000000`00000003 0000029d`78180000 0000029d`78180000 00000000`00000000 : ntdll!RtlpHeapHandleError+0x12
000000ca`7dafe780 00007ffc`bccca8e9 : 0000029d`78180000 0000029d`8faaf9d0 00000000`00000000 00000000`00000000 : ntdll!RtlpHpHeapHandleError+0x7a
000000ca`7dafe7b0 00007ffc`bcc6646d : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ntdll!RtlpLogHeapFailure+0x45
000000ca`7dafe7e0 00007ffc`bcbffc11 : 0000029e`4e1df3a0 0000029d`78180000 00000000`00000000 00000000`00000000 : ntdll!RtlpFreeHeapInternal+0x663ed
000000ca`7dafe890 00007ffc`bad54ca6 : 0000029e`4e1df380 000000ca`7dafe980 000000ca`7dafe980 00000000`00000000 : ntdll!RtlFreeHeap+0x51
000000ca`7dafe8d0 00007ffc`b0f653c2 : 000002a0`c977ed50 000000ca`7dafebf0 0000029d`e8cc98e0 00000000`00000000 : rpcrt4!RpcStringBindingComposeW+0xb6
000000ca`7dafe940 00007ffc`b0f681c5 : 0000029e`4e1df140 000002a0`c977ed50 00000000`00000000 00000000`00000000 : AudioSes!GetAudioServerBindingHandle+0x3e
000000ca`7dafe980 00007ffc`b0f63dc9 : 000002a0`c977ed50 00000000`000186a0 00000000`00000000 00007ffc`b9ac2c50 : AudioSes!CAudioClient::InitializeAudioServer+0x65
000000ca`7dafeaf0 00007ffc`b0f61317 : 00000038`00000000 000000ca`7daff2d8 00007ffc`b0f74330 000000ca`7daff1f8 : AudioSes!CAudioClient::SetupAudioStreamWithAudioSrv+0x2c9
000000ca`7dafec80 00007ffc`b0f683b4 : 00000000`00040000 419e1c97`4d5e49d6 097585cb`6b4f21b5 00000000`00040000 : AudioSes!CAudioClient::InitializeInternalHelper+0xdf
000000ca`7daff280 00007ffb`ff808194 : 000002a0`c977ed50 00000000`000186a0 000002a0`c977ed50 000000ca`7daff101 : AudioSes!CAudioClient::Initialize+0xe4
000000ca`7daff380 00007ffb`ff8050d3 : 00000000`00000001 00000000`00000000 2aaaaaaa`aaaaaaab 00000000`00000002 : FairlightPage!GetDLLUIInterface+0x4c8a94
000000ca`7daff460 00007ffb`ff7294d0 : 00007ffc`0009cbd8 00007ffc`00a49810 00000000`00000000 000000ca`7daff2f8 : FairlightPage!GetDLLUIInterface+0x4c59d3
000000ca`7daff770 00007ffb`ff40a8ee : 00007ffc`00a49810 0000029d`28040701 00007ffc`00a49810 0000029d`28040701 : FairlightPage!GetDLLUIInterface+0x3e9dd0
000000ca`7daff7e0 00007ffb`ff40aecd : 00007ffc`00a49810 00007ffc`00a49810 0000029d`280407a0 00007ffb`ff40a980 : FairlightPage!GetDLLUIInterface+0xcb1ee
000000ca`7daffd10 00007ffc`67abd24c : 00000000`00000000 00007ffc`a4453403 00000000`00000000 0000029d`280407a0 : FairlightPage!GetDLLUIInterface+0xcb7cd
000000ca`7daffd40 00007ffc`a4454f7f : 0000029d`280407a0 00000000`00000000 0000029d`280407a0 0000029d`280407a0 : msvcp120!_Call_func+0x14
000000ca`7daffd80 00007ffc`a4455126 : 00007ffc`a450cb80 00000000`00000000 00000000`00000000 00000000`00000000 : msvcr120!_callthreadstartex+0x17
000000ca`7daffdb0 00007ffc`bca17bd4 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : msvcr120!_threadstartex+0x102
000000ca`7daffde0 00007ffc`bcc2ced1 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : kernel32!BaseThreadInitThunk+0x14
000000ca`7daffe10 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ntdll!RtlUserThreadStart+0x21


SYMBOL_NAME: audioses!GetAudioServerBindingHandle+3e

MODULE_NAME: AudioSes

IMAGE_NAME: AudioSes.dll

STACK_COMMAND: ~114s ; .ecxr ; kb

FAILURE_BUCKET_ID: HEAP_CORRUPTION_c0000374_AudioSes.dll!GetAudioServerBindingHandle

OS_VERSION: 10.0.18362.1

BUILDLAB_STR: 19h1_release

OSPLATFORM_TYPE: x64

OSNAME: Windows 10

FAILURE_ID_HASH: {ccfd83b8-b6c4-3923-ab3d-ec5d200e1134}

Followup: MachineOwner
---------
Offline

Scott Brickert

  • Posts: 14
  • Joined: Tue Mar 13, 2018 5:58 pm
  • Location: Crested Butte, CO
  • Real Name: Scott Brickert

Re: Resolve crashing on delivery

PostTue Feb 18, 2020 12:04 am

Thanks for the the ideas on this thread.

I slowed the rendering down to 50 and managed to get the 30m15s timeline rendered. What a relief!
Windows 10; Resolve 16.1 free
Ryzen 5 2600@3.9GHz, 32gb DDR4 2666
NVIDIA GeForce GTX 1070 (8GB DDR5)
1TB NVMe SSD at 1700MB/s

Return to DaVinci Resolve Beta Feedback

Who is online

Users browsing this forum: MarcusJB and 13 guests