Blackmagic Video Assist 5” 12G 2160p issue

Questions about ATEM Switchers, Camera Converter and everything live!
  • Author
  • Message
Offline

vytenis.gadliauskas

  • Posts: 2
  • Joined: Mon Jan 20, 2020 8:23 pm
  • Real Name: Vytenis Gadliauskas

Blackmagic Video Assist 5” 12G 2160p issue

PostMon Jan 20, 2020 8:44 pm

Hello everyone,

Our institution bought Blackmagic Video Assist 5” 12G HDR, and we intend to use it with Sony PXW-FS7M2 camera via HDMI. Everything is working fine for 2160p25/29,97fps, 10bit (Cine-EI mode), however if HDMI output of camera is switched to 2160p50/59,94fps, 10bit, Video Assist starts flickering and freeze. Not even power button works. The same output from camera is working fine with 4K TV's that we have at the spot. Also, we tested this format with several HDMI cables, even 30cm of length and it does not work. Video Assist runs the latest firmware (3.0.1). One more thing, for some unknown reason, this Video Assist came without protective metal grill on one side, you can see this at the end of the all explaining video:



Could someone help us with this case?

Thank you.
Offline

Raphaël Jacquot

  • Posts: 384
  • Joined: Wed Aug 29, 2012 4:15 pm

Re: Blackmagic Video Assist 5” 12G 2160p issue

PostTue Jan 21, 2020 6:37 pm

sounds like you need to RMA the thing
Offline

Howard Roll

  • Posts: 565
  • Joined: Fri Jun 03, 2016 7:50 am

Re: Blackmagic Video Assist 5” 12G 2160p issue

PostTue Jan 21, 2020 8:23 pm

The metal grille is coming later in a firmware update.
Offline

Dave Del Vecchio

  • Posts: 537
  • Joined: Mon Nov 25, 2013 10:25 am

Re: Blackmagic Video Assist 5” 12G 2160p issue

PostWed Jan 22, 2020 5:23 am

Although I don't have one of these new Video Assist 12G HDR units myself yet, my best guess (based on experience with other Blackmagic devices) is that this is probably a chroma subsampling (4:2:2/4:2:0) or color depth (8-bit/10-bit) issue with the HDMI signal. A second possibility is some kind of HDMI EDID detection issue (also related to the signal format).

A bit of background. Up through HDMI 1.4, which supports video signals up to 2160p30 resolution, HDMI always used at least 4:2:2 chroma subsampling (or in some cases RGB/4:4:4). With the introduction of HDMI 2.0 and support for 2160p50/2160p60 video signals, the HDMI spec boosted the total possible video bandwidth of an HDMI signal from the 10.2 Gbps of HDMI 1.4 to 18 Gbps in HDMI 2.0. The HDMI 2.0 spec also introduced 4:2:0 sub-sampling for the first time, which made it possible to fit a 2160p60 video signal (@ 4:2:0 sampling) within the 10.2 Gbps bandwidth of the older spec (2160p50/60 @ 10-bit 4:2:2 requires the full 18 Gbps of bandwidth).

This meant that it was possible to take the 10.2 Gbps HDMI 1.4 chips and apply a few firmware tweaks to make them HDMI 2.0 compatible. These HDMI chips would only support 4:2:0 sampling for higher frame rate 4K signals (2160p50/60), but the HDMI specifications let device manufacturers support a subset of the possible signal formats in a particular HDMI version and still claim compatibility. So these could be considered HDMI 2.0 devices without supporting the full 18Gbps bandwidth.

The practical affect of this is that many early HDMI 2.0 devices (both on the output and display side of things) only supported this 2160p50/60 4:2:0 signal format. It is also possible that staying within the 10.2 Gbps bandwidth helped maximize device compatibility and minimize cable bandwidth issues.

At any rate the HDMI output of a lot of early cameras (including those from Sony, Canon, and Panasonic) that could record at 2160p50/60 was similarly limited to 4:2:0 over HDMI at that resolution. Even if the camera could record internally at 2160p60 10-bit 4:2:2, the HDMI output was often still 8-bit 4:2:0.

I am not sure about the FS7 Mark 2, but the original FS7 Mark I definitely had this limitation (some discussion about this here):
https://us.community.sony.com/s/questio ... anguage=es

As HDR and 18Gbps HDMI chips have become more prevalent, this situation has started to change somewhat, with more recent camera releases supporting 2160p50/60 10-bit 4:2:2 output over HDMI (although these cameras often have an option to select the subsampling when outputting at 2160p50/60 for compatibility with older devices).

The overall effect of these issues, is that since there are more signal format options in the HDMI 2.0+ spec used for 2160p50/60 signals, there are more opportunities for signal format incompatibilities between devices or EDID negotiation issues.

In particular, I have noticed that Blackmagic devices often do not like 2160p50/60 @ 8-bit 4:2:0 signals on input and will often behave strangely when given this signal format. I've noticed issues with the Teranex Mini HDMI to SDI units, the HyperDeck 12G and, and DeckLink devices when fed this signal format. The exact problem may vary depending on the device but I have seen screen flickering/scrolling issues like in your video. These same devices often work fine when fed 2160p25/30 video (which is always 4:2:2) or 2160p50/60 at 10-bit 4:2:2.

Now, I don't know for sure if that is the problem with the new Video Assist 12G, but that would be my initial guess. Unfortunately, it may be a little difficult to troubleshoot this problem unless you have another device that can output 2160p50/60 video over HDMI to test with.
Offline

vytenis.gadliauskas

  • Posts: 2
  • Joined: Mon Jan 20, 2020 8:23 pm
  • Real Name: Vytenis Gadliauskas

Re: Blackmagic Video Assist 5” 12G 2160p issue

PostWed Jan 22, 2020 3:50 pm

Thank you Dave Del Vecchio, I checked the Video Assistant with PC, UHD 2160p/50, Y'CbCr 4:2:0 and it is showing the same results - flickering and freezing after that. Sony is cheating for HDMI output, they don't say anything about Y'CbCr 4:2:0 at 50 or 60 fps. So FS7M2 uses the same old hardware as original FS7.

Dear Blackmagic team, could you please add support for Y'CbCr 4:2:0 at UHD 2160p/50/59.94 resolutions in Video Assistant 12G?

I think more users will have this questions after some time.

Thank you very much.

Offline

scotmacman

  • Posts: 66
  • Joined: Sat Dec 07, 2019 9:38 am
  • Real Name: Neil MacLennan

Re: Blackmagic Video Assist 5” 12G 2160p issue

PostWed Jan 22, 2020 11:44 pm

Dave,
Whether or not your post got to the bottom of the matter doesn't take away from a great and detailed explanation. I learned a lot. Thank you!

Return to Live Production

Who is online

Users browsing this forum: BLITZTEL, MSN [Bot], RichardJolly and 22 guests