Discrepancy between Gen5 LUT, RAW Settings and Managed

Do you have questions about Desktop Video, Converters, Routers and Monitoring?
  • Author
  • Message
Offline

Christian Korahyn

  • Posts: 35
  • Joined: Fri Oct 27, 2017 1:44 pm

Discrepancy between Gen5 LUT, RAW Settings and Managed

PostSun May 16, 2021 3:43 pm

Hey
can someone explain why my BRAW image doesn't look the same between these settings?

1.
Color Management Off

RAW Settings:
Gen 5
ColorSpace: Blackmagic Design
Gamma: Blackmagic Design Film

LUT: Blackmagic Gen 5 Film to Extended Video

2.
Color Management On (REC709)
(RAW Settings managed by Color Management)

3.
Color Management Off
RAW Settings
Gen 5
ColorSpace: Blackmagic Design
Gamma: Blackmagic Design Extended Video


At least 1 and 3 should look the same.

I'm having a huge problem with alpha mattes in the managed workflow and I'm trying to switch to using the LUT or ColorSpaceTransform node (which also looks different).
Offline

CaptainHook

Blackmagic Design

  • Posts: 1886
  • Joined: Wed Aug 22, 2012 4:50 am
  • Location: Melbourne, Australia
  • Real Name: Hook

Re: Discrepancy between Gen5 LUT, RAW Settings and Managed

PostTue May 18, 2021 2:42 am

#2 is not expected to look the same since "Extended Video" is not Rec.709 and does not use 709 primaries (Blackmagic Video DOES use 709 primaries but has more highlight roll off - read about the differences in detail here: viewtopic.php?f=2&t=125084)

Can you post images of what you're seeing with how #1 and #3 differ and if you have gamut compression or highlight recovery enabled or not? I assume this is Resolve 17.2 since Gen 5 is available in RCM for you?

Would also help if you can post a single frame from the braw clip, use "export frame" from the RAW tab. Thanks.
**Any post by me prior to Aug 2014 was before i started working for Blackmagic**
Offline

Howard Roll

  • Posts: 1390
  • Joined: Fri Jun 03, 2016 7:50 am

Re: Discrepancy between Gen5 LUT, RAW Settings and Managed

PostTue May 18, 2021 4:36 pm

For transforming from G5 Film to Extended Video the CST and the Camera Raw tab are identical, and the LUT is identical if applied in the Camera Raw tab or attached to a node.

There is a microscopic discrepancy between the LUT and the CST/CR tab. It looks like the midpoint is slightly higher for the LUT. What I'm seeing is more like a rounding error than anything else.

Fun Fact, the Camera Raw panel allows for at least four digits of input precision, yet is visually rounded to two. For example the midpoint of BMD film isn't .41 rather .409 so for Extended Video I though (naturally) it would be .384 but it's actually closer to .3835.

Good Luck

G5.jpg
G5.jpg (172.55 KiB) Viewed 294 times
Offline

CaptainHook

Blackmagic Design

  • Posts: 1886
  • Joined: Wed Aug 22, 2012 4:50 am
  • Location: Melbourne, Australia
  • Real Name: Hook

Re: Discrepancy between Gen5 LUT, RAW Settings and Managed

PostTue May 18, 2021 10:21 pm

Yes, there will be some precision loss in the 3DLUT compared to the RAW tab decode but its usually minimal or "close enough" and expected. Especially with some of the Gen 5 LUTs that are also reversing and then reapplying gamut compression etc.

Ext Video should be 40.9 FYI, not 38.4.

And yes, Resolves input display is rounded but for practical purposes past one or two decimal places starts to get fairly 'academic' about it anyway.

Not that it matters for most users but the mid grey point as used in the SDK for Film is 0.383561643835616 which we often just say is "38.4%". Extended Video etc is 0.40900772886415 which I generally talk about as 40.9%.
**Any post by me prior to Aug 2014 was before i started working for Blackmagic**

Return to Post Production

Who is online

Users browsing this forum: No registered users and 8 guests