Side Handle Not Working

The place for questions about shooting with Blackmagic Cameras.
  • Author
  • Message
Offline

James McDonagh

  • Posts: 185
  • Joined: Fri Dec 01, 2017 5:38 pm

Side Handle Not Working

PostSat Feb 03, 2018 12:43 am

Hello,

I have recently acquired an URSA Mini Pro. On said camera is a handle on the right hand side that I can grip. This grip comes with a host of buttons. One of these buttons is record. However, neither the record button not any of the other buttons on the grip seem to have any communication with the camera. Is there anyway I can fix this?

Many thanks,
James
Offline

Denny Smith

  • Posts: 13062
  • Joined: Thu Aug 01, 2013 4:19 pm
  • Location: USA, Northern Calif.

Re: Side Handle Not Working

PostSat Feb 03, 2018 12:57 am

Is the Lanc jumper cable plugged into both the grip and camera body? The kit came with this short cable with a straight and a 90-degree right angle TRS 1/8 Mini plugs on it, this cable connects to the back side of the grip, next to the Rosette Mount and plugs into the small 1/8 socket on the camera side. See the camera manual for details.
Cheers
Denny Smith
SHA Productions
Offline

James McDonagh

  • Posts: 185
  • Joined: Fri Dec 01, 2017 5:38 pm

Re: Side Handle Not Working

PostSat Feb 03, 2018 12:59 am

Denny Smith wrote:Is the Lanc jumper cable plugged into both the grip and camera body? The kit came with this short cable with a straight and a 90-degree right angle TRS 1/8 Mini plugs on it, this cable connects to the back side of the grip, next to the Rosette Mount and plugs into the small 1/8 socket on the camera side. See the camera manual for details.
Cheers


Hi Denny,

No it's not. I'd imagine that's the problem. Many thanks for your help.
Offline

Denny Smith

  • Posts: 13062
  • Joined: Thu Aug 01, 2013 4:19 pm
  • Location: USA, Northern Calif.

Re: Side Handle Not Working

PostSat Feb 03, 2018 1:11 am

Yes, it needs the cable to get a connection between the camera dB grip handle.
Cheers.
Denny Smith
SHA Productions
Offline

LCsxsw

  • Posts: 2
  • Joined: Thu May 30, 2019 6:25 pm
  • Real Name: Lauren Caldwell

Re: Side Handle Not Working

PostTue Feb 11, 2020 3:26 pm

Does anyone have any suggestions when the arm won't communicate after being plugged in? Neither the front nor side port seems to work with the handle.

Thanks,

LC
Offline

Neil-G

  • Posts: 29
  • Joined: Wed Feb 12, 2020 8:51 pm
  • Real Name: Neil Goodwill

Re: Side Handle Not Working

PostMon Jul 26, 2021 6:33 pm

Have you tried the menu options for the LANC connection?

Return to Cinematography

Who is online

Users browsing this forum: dondidnod, Google [Bot] and 22 guests