New UltraStudio Recorder 3G

Getting started with a Blackmagic product? Ask questions here about setup and installation.
  • Author
  • Message
Offline

hakkinen5

  • Posts: 2
  • Joined: Mon Nov 28, 2022 2:58 pm
  • Real Name: Dale Mounsey

New UltraStudio Recorder 3G

PostMon Nov 28, 2022 3:12 pm

Hi, any help appreciated please. I've just unpacked a brand new Ultrastudio Recorder 3G. I'm familiar with this product as I've used several before. I've connected this one to a new PC laptop with Thunderbolt4, a brand new Mac Mini M1, and a recent MacBook Pro, using 3 different thunderbolt cables. Not once has the LED beside the Thunderbolt port EVER illuminated on the device. As such, the computers at best tell me the device has "limited functionality". As such, the BlackMagic Desktop Video does not detect any sources. The LED indicator on the device should light immediately on plugging in with a genuine thunderbolt cable right? Is it possible this unit is faulty out of the box? Again, any help or advice appreciated. Thanks.
Offline

hakkinen5

  • Posts: 2
  • Joined: Mon Nov 28, 2022 2:58 pm
  • Real Name: Dale Mounsey

Re: New UltraStudio Recorder 3G

PostWed Nov 30, 2022 7:46 am

Problem solved. Turns out it was the cables I was using not being Thunderbolt 3 compliant. Apparently cables that come with brand new Ipads are not Thunderbolt - just USB-C. I've learnt a cable lesson.

Return to Getting Started

Who is online

Users browsing this forum: No registered users and 44 guests