No SSD after formatting Blackmagic 4k

Getting started with a Blackmagic product? Ask questions here about setup and installation.
  • Author
  • Message


  • Posts: 1
  • Joined: Thu Apr 23, 2015 2:55 pm

No SSD after formatting Blackmagic 4k

PostThu Apr 23, 2015 3:01 pm


My blackmagic 4k isn't recognizing my SSD card, not sure what's up. I have updated my camera to the most recent upgrade and when I have my SSD in the camera all the other buttons on the menu are lit up/highlighted (Metadata, settings, focus peaking, meters, and frame guides) but the format disk button isn't lit up and I'm unable to click it. My SSD card is working and recognized by my computer, I even tried formatting it on my computer in the way the manual described but the camera still says no SSD. Has this happened to anyone? Any suggestions? Oh and it's from the recommended list! It's a Kingston SSDNow V300 240GB

Any help would be awesome, I'm kind of freaking out.


Tony Rivera

Blackmagic Design

  • Posts: 3423
  • Joined: Mon Aug 12, 2013 4:52 pm
  • Real Name: Tony Rivera

Re: No SSD after formatting Blackmagic 4k

PostThu Apr 23, 2015 9:43 pm

That particular model of SSD doesn't appear to be on the approved list for the BMPC4k. This could be the problem as it may not meet the requirements for use with the camera.

Follow us on Instagram:
User avatar


  • Posts: 203
  • Joined: Wed Sep 11, 2013 1:32 am
  • Location: Los Angeles, CA

Re: No SSD after formatting Blackmagic 4k

PostThu Apr 23, 2015 10:39 pm

V300 disks definitely did, at one point, work. Not for 4K raw though. I used it for 2.5K raw on my BMCC back in the day with no problems, and I used it for 4K ProRes in the BMPC briefly. It used to be on their legacy compatible list for the BMCC SSDs.

Long story short, I'd definitely get one off of the current list.
Benjamin Lebeau
Editor/Colorist, Sandwich Video
User avatar

Peter J. DeCrescenzo

  • Posts: 2313
  • Joined: Wed Aug 22, 2012 6:53 am
  • Location: Portland, Oregon USA

Re: No SSD after formatting Blackmagic 4k

PostThu Apr 23, 2015 11:29 pm

On a related note:

Last week I bought from B&H a "Transcend 256 GB SSD 370 (TS256GSSD370)" which is on BMD's current list of SSDs certified for ProRes recording in the BMPC-4K. My camera is running 1.9.10 firmware, the most current version for the BMPC-4K.

Note: This disk is a "thin" form factor drive (7mm?), and does NOT ship with a plastic shim/spacer to prevent it from wobbling around inside a BMPC-4K or BMCC camera.

As expected, I got the "No SSD" prompt when I first inserted the drive in my camera. But the "Format Disk" button was greyed-out in the cam's menu, no matter what recording format or fps was selected, and the cam wouldn't record onto the disk.

I was able to format the SSD on my Mac using 2 different drive docks, both exFat & HFS+. But the camera still reacted to the disk with the No SSD prompt, and couldn't format or record on the disk.

I returned the Transcend disk to B&H for a full refund, and ordered from them a "Kingston 240 GB HyperX 3K (SH103S3/240G)". I already own one of these disks and it's always worked perfectly for ProRes recording in my BMPC-4K. Only reason I tried the Transcend is because it was a lot less expensive than the Kingston. The Kingston 240 GB HyperX 3K is a "9mm" thickness drive, so it fits inside my camera perfectly; nice and snug. The Kingston 240 GB HyperX 3K drive I received from B&H today formats & records ProRes in my BMPC-4K without any problems.

I don't know if the "Transcend 256 GB SSD 370 (TS256GSSD370)" I bought was defective, or if Transcend has changed the drive since BMD tested them. I didn't bother checking if Transcend has a firmware update for the drive; I probably should have, but I didn't like the idea of using a thin SSD without a shim/spacer in my BMPC-4K.



Return to Getting Started

Who is online

Users browsing this forum: No registered users and 12 guests