Sporadic black frames with DeckLink 8K Pro at 4K60p.

Ask software engineering and SDK questions for developers working on Mac OS X, Windows or Linux.
  • Author
  • Message
Offline

thorfdbg

  • Posts: 2
  • Joined: Fri Oct 18, 2019 7:08 am
  • Real Name: Thomas Richter

Sporadic black frames with DeckLink 8K Pro at 4K60p.

PostFri Oct 18, 2019 7:15 am

We are currently using a DeckLink 8K pro with the latest 11.4 software SDK on Linux, SDI input from a BlackMagic 4.6K camera running at 4K60p. Our software registers a VideoInputFrameArrived() method as described in the SDK documentation. Capturing works flawless at 2K60p, but at 4K60p, we get sporadic (irregular pattern, probably twice a minute) black frames. That is, the frame delivered to the hook is entirely black, no useful observable sample. Next frame is then correct again. We used an older 10.x SDK before, but the issue remains with 11.4.

Any hints or advises?
Offline

Brendan Dower

Blackmagic Design

  • Posts: 37
  • Joined: Thu Oct 10, 2019 5:56 am
  • Real Name: Brendan Dower

Re: Sporadic black frames with DeckLink 8K Pro at 4K60p.

PostTue Oct 22, 2019 4:43 am

Hi Thomas,

Can you please provide more information about your system?
What distro of Linux are you using?
What hardware are you running on your computer? (motherboard, GPU, other PCIe slots etc)
Is this happening with just one video input on the card or on multiple?
What is the pixel format?

If you let me know these specs I can attempt to recreate the issue locally.
Brendan Dower
Blackmagic Design Developer Support
Offline

thorfdbg

  • Posts: 2
  • Joined: Fri Oct 18, 2019 7:08 am
  • Real Name: Thomas Richter

Re: Sporadic black frames with DeckLink 8K Pro at 4K60p.

PostTue Oct 22, 2019 10:00 am

The system is a 64-bit Debian 10 (Buster) with a 4.19.67 kernel (kernel coming from debian). The motherboard is an Asus ROG STRIX X570-F GAMING, with an AMD Ryzen 9 3900X 12-Core Processor. In the PCIe bus, we have a Mellanox Technologies MT27520 ethernet, a GeForce GTX 760 and the 8K grabber card. Only one video input is connected and grabbed, though the CPU load can be quite high as it is encoding the video in real time. The pixel format is 10bit 422 YUV.

I already swapped the cable, but without making any progress on the matter.
Offline

markkitus

  • Posts: 3
  • Joined: Fri Jul 13, 2018 3:27 am
  • Real Name: Marcos Nuñez

Re: Sporadic black frames with DeckLink 8K Pro at 4K60p.

PostFri Jan 24, 2020 4:03 am

That error usually happens when the decklink is connected to a pciex of less speed, for example placing it in the pciex 16_3 which is 4x, 8k needs an 8x pciex16 set to change it slot.
The mother only supports 1 16x board, one 8x board and one 4x board. In the Pciex slots of 16,and you have the 16x video card, the 8x 8x decklink and the 8x Mellanox Technologies MT27520

Return to Software Developers

Who is online

Users browsing this forum: No registered users and 3 guests